Nissan Forum banner

1 - 19 of 19 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I installed a Hot Shot header this past weekend and the installation went pretty well. However, here's my problem: I drove the Spec-V most of Saturday and had no problems, but Sunday morning I took a trip to 7-11 and noticed that the "Service Engine Soon" light had come on. The "Service Engine Soon" light is steady (not blinking) and according to the drivers manual this indicates that there is an emissions malfunction. Has anyone else had this problem? What can I do to check the source of the problem?

I'm hesitant on taking it back to the dealership, only have 4,500 miles and I think after the header modification I may have voided my warranty. Any help is appreciated.

Thanks,

Brian
 

·
Registered
Joined
·
369 Posts
ses/ mil light

Yes the light is on. When you put the header in you removed a cat. The ecu knows this because the second o2 sensor makes shure the first one is working properly, it also looks for a difference on th a/f ratio. Both sensors now read the same hence the ses/mil light this will not cause a problem the light is a eye sore. Move your second o2 sensor behind the second cat and reset your ecu. the light will go away after that damn. (obII system)
btw I am moving my o2 sensor today I will take pics of the procedure including wire routing.

mike
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Header Problems

Mike,

You've been a real help through all of this and I appreciate all that you have posted. I'm sort of confused on your suggestion on moving the O2 sensor. Where do I move the second O2 sensor to? How do you reset the ecu? (disco battery). Will you be posting the pics on the forum?

Thanks again,

Brian
 

·
Registered
Joined
·
369 Posts
header

I will post pics to the forum if I am able. The sencond o2 sensor should be relocated to your midpipe just behind the second cat. It looks like a cacoon(cat) and your midpipe starts from that point. Just go to a exhaust shop and have them tap and weld a bung in about 2-4in from the cat also do not forget to get a plug for the empty hole in your header. as for resetting the ecu b14 chasis sentras reset with the battery unplugged for 2hrs, but the b15 does not you may have to leave it unhooked overnite. The ecu will eventually reset itself after 100 ignition cycles or you can go to the stealership and have them reset it(takes 2min)


mike
questions
[email protected]
1-843-906-6641
 

·
Registered
Joined
·
369 Posts
specva

brian if you go to the dealership just tell them the gas cap was loose when you startrd the car. doing that is known to make the ses/mil come on the dealership should not ask any questions
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Thanks for the suggestion. I'm working on getting an Stromung exhaust and talked to the guy he had mentioned that the resonator will have a bung on it. Will this resolve my problem besides having the ecu reset?

Brian
 

·
Registered
Joined
·
369 Posts
STROMUNG EXHAUST

If you get the exhaust with the o2 location it will fix the problem.
I will be working on my car in the next hour so I will let you know how it goes
 

·
Registered
Joined
·
369 Posts
header

Just got my new midpipe fixed my loud exhaust noise. Also I relocated the o2 sensor have pic of the procedure I will post them later. Still have to go to the dealership to get my ecu reset. Scott(stromung exhaust) said he more midpipes made just like mine. So they are ready to ship


mike
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #10
Cortrim1

How long did it take you? It sounds like it was a fairly simple install maybe I'm wrong. Does the midpipe make a difference in performance? How much did the midpipe run you? What does the resonator do? look like?

I'm fairly new to the performance market but, trying to do everything my self to begin a hobby and save money on labor as well. That is what driving all of my questions. Again, I appreciate all of your help and looking forward to your pics.

Brian
 

·
Registered
Joined
·
369 Posts
Re: Cortrim1

SpecVA said:
How long did it take you? It sounds like it was a fairly simple install maybe I'm wrong. Does the midpipe make a difference in performance? How much did the midpipe run you? What does the resonator do? look like?

I'm fairly new to the performance market but, trying to do everything my self to begin a hobby and save money on labor as well. That is what driving all of my questions. Again, I appreciate all of your help and looking forward to your pics.

Brian
it took about 2hrs total. Most of it from finding a spot to run the wirers for the o2 sensor. I have pics of the midpipe and where I ran the wirers. email me and I will send them to you I am at work so use this address

[email protected]
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #12
i noticed a fuse for the O2 sensor, has anyone tried taking that out? I did and the SES didnt come on. Some one with the HS Header try it for like a day, and see if the ECU turns the light off.
 

·
Registered
Joined
·
369 Posts
o2 sensor

If you remove the fuse the ses light should still come on. It may not come on today but it will eventually. My ses did not turn on for three days. My light is off now, I relocated the o2 sensor and reset the ecu also checked the a/f while it was pluged in to the consult II.
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #14
Lights Off

Everything back to normal now? What were the results on the A/F?
 

·
Registered
Joined
·
369 Posts
a/f

the number were boucing due to a loose plug on the header, but once it was tight the reading were around 95-98%. all within spec
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #16
Results

Excellent, so everything turned out great. So will Stromung to be putting the exhaust w/ resonator and bung into production? Will you be making the dyno run this weekend?
 

·
Registered
Joined
·
369 Posts
exhaust

yes stromung will be putting this exhaust into production. Not shure when I can get on the dyno. I need to get some driving time in so my ecu can adjust because it was just reset. It takes a few days for the ecu to adjust to mods so I have been told, but I will have dyno results by next week at the latest. check out b15sentra someone just posted there results with the aebs header there numbers should be close to mine because we have the same mods except I have a different header
 

·
Registered
Joined
·
172 Posts
warranty or no warranty?

Federal law prohibits a dealer from voiding your warranty just because you are using aftermarket speed equipment, with only two exceptions: the warranty can be voided if the aftermarket part causes damage or adversely affects the emissions or the emissions system. In recent documents produced by the SEMA (Specialty Equipment Market Association), a trade association-representing specialty automotive parts manufacturers, and the following quotes have been extracted:

"The vehicle manufacturer is not allowed to void the vehicle warranty just because aftermarket equipment is installed on the vehicle. This protection for consumers is the result of a parts self-certification program developed by the Environmental Protection Agency (EPA) and the Specialty Equipment Market Association (SEMA).

"Under the program, if a parts maker completes the EPA process of self-certifying its parts, the vehicle manufacturer cannot void the warranty even if the certified part has failed and is directly responsible for the warranty claim. In cases where such a failed aftermarket part is responsible for a warranty claim, the manufacturer must arrange a settlement with the part manufacturer, but the new vehicle warrant is not void under the law.

"If the failure to honor a claim involves the new-vehicle warranty, and it appears that the manufacturer is improperly denying a claim, the incident should be reported to the Federal Trade Commission (FTC). The FTC is responsible for monitoring compliance with the warranty law; the agency's telephone number is 202/326-3128
:D
 

·
Registered
Joined
·
45 Posts
i hate to rehash such a old thread... BUT

i am planning on puttin a nismo header (i got hella price) on in the next few weeks. this header does Not have a cat on it... i have planned on relocating my o2 sensor..

2 questions
a. where do you get o2 sensor wire extensions/bung's?

b. now that you have been running on this for a while
has it adversly affected your gas milage. has ses light come on yet? any sort of negative problems. or have you heard of any better way to elimnate ses light

Chris
 
1 - 19 of 19 Posts
Top