Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, so i just figured how to pull the CEL code on my 1995 altima. It gave me 10 slow flahes and 5 fast flashes. So i assume its 105. and its a EGR and ERG Canister Control Solenoid Valve. Has anyone here experienced the same code? Can you please tell me what i can do fix the problem? Thank you in advance.

ryan
 

·
Registered
Joined
·
189 Posts
The trouble code implies that the solenoid voltage is bad. Could be the solenoid has failed, or the electrical connection at the solenoid is bad. Best thing you could do is go to the local Autozone or similar store and buy an aftermarket shop manual for your car ... they cost around $15. The manual should give you some trouble-shooting and testing information on these kind of problems.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
so i checked the egr valve, and it moves freely when pressed up on the diaphram. while enigine is on, i pressed on the diaphram and the engine idle rough, so i believe the egr valve is still good. then i checked the voltage from the egr solenoid valve wire harness and it is good, 12v. then when i touch the connector from the wire harness to the connector of the egr solenoid valve, i hear it clicking, so i assume that is good. so now i check the BPT, i plug one of the port and blew into the other port and i hear air coming out, is that normal? I also noticed that my exhaust pipe is slight crack, can that cause the check engine light to come on? Please, any help would be great.
 
1 - 3 of 3 Posts
Top