Nissan Forum banner

1 - 11 of 11 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
my turn signals stopped working,

hazard fuse is good and so is turn sig fuse

is there a relay some where, they do absolutely nothing
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Did you just recently replace your bulbs to a higher wattage one? Like Hyper whites? I did that before and I had the same problem. I fixed it by putting the old bulbs back on.
 

·
Banned
Joined
·
809 Posts
wierd, was it a new turn signal housing?... maybe you coulda fractured the bulbs.. wait, you said hazards work right??? thats the damn turns right there, i think that your switch in the turn signal switch might be Fudgedup
 

·
Team Serious
Joined
·
2,133 Posts
i had the problem
all i did to get them to work was shake the wire that was going into the bulb while the blinker was on... i then taped the wire to the fender so it wouldn't move...


its probably a loose connection!!!
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #6
would a loose connection cause them all to go out?

no hazards

no turns
 

·
Registered
Joined
·
64 Posts
did you just replace your stereo becuz that happend to me and i didnt but the relays on tight to the hazards and nothing werked until i pushed it in
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #9
hmmmm, i did just replace my stereo, ill have to go check it out
 

·
Registered
Joined
·
323 Posts
silverbizullet said:
hmmmm, i did just replace my stereo, ill have to go check it out
yea the harness for your hazards also has your turns going through it and if I'm not mistaken your parking lights as well, if it's not pushed in all the way the circut is broken and nothing works, just set it back in place
 
1 - 11 of 11 Posts
Top