Nissan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
so yea...i was cleaning out my center console...i took it out...cleaned it thoroughly....nd watever.....nd put it back on...after a small struggle because i put the screws into the holes of the plastic thing before putting the console back.....anyways..after putting it on nd screwing the screws....it looks fine....but when i went to start the car.....the ebrake light was on....ok...so my ebrake was on....so i took the ebrake off.....but the light didn't turn off....so...i'm figuring...the lil switch on the bottom of the ebrake was stuck or somethin right??....well...i checked it...nd it's workin fine....w/ the lil spring nd everythin...so i dunno wat it can be....i think it's like an electrical connection somewhere....but any ideas guys (and gals :D) ? :loser:
 

·
Registered
Joined
·
751 Posts
erixpulsar said:
so yea...i was cleaning out my center console...i took it out...cleaned it thoroughly....nd watever.....nd put it back on...after a small struggle because i put the screws into the holes of the plastic thing before putting the console back.....anyways..after putting it on nd screwing the screws....it looks fine....but when i went to start the car.....the ebrake light was on....ok...so my ebrake was on....so i took the ebrake off.....but the light didn't turn off....so...i'm figuring...the lil switch on the bottom of the ebrake was stuck or somethin right??....well...i checked it...nd it's workin fine....w/ the lil spring nd everythin...so i dunno wat it can be....i think it's like an electrical connection somewhere....but any ideas guys (and gals :D) ? :loser:
I'd be checking that switch real close. Try cleaning it with some kind of electrical cleaner/lube squirty stuff. My ebrake light comes on if the handle is up even half a click.

Does anyone have the little door that covers the cubby in the console? I only seen em on sport coup consoles. Me thinkin it might be another (small) upgrade for the sedan.
 

·
Registered
Joined
·
193 Posts
erixpulsar said:
so yea...i was cleaning out my center console...i took it out...cleaned it thoroughly....nd watever.....nd put it back on...after a small struggle because i put the screws into the holes of the plastic thing before putting the console back.....anyways..after putting it on nd screwing the screws....it looks fine....but when i went to start the car.....the ebrake light was on....ok...so my ebrake was on....so i took the ebrake off.....but the light didn't turn off....so...i'm figuring...the lil switch on the bottom of the ebrake was stuck or somethin right??....well...i checked it...nd it's workin fine....w/ the lil spring nd everythin...so i dunno wat it can be....i think it's like an electrical connection somewhere....but any ideas guys (and gals :D) ? :loser:
I did the EXACT same thing on my 85 Pulsar. The stupid brake light would not go off. Then sometimes while I was driving it would randomly go off and on. I think the problem is that the plug at the end of the brake handle (inside the console) might be touching metal. I had metal touching down there. I wrapped electric tape around it and it stopped doing that. This also happened at the same time my alternator was going out.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #5
winstonsmith said:
I did the EXACT same thing on my 85 Pulsar. The stupid brake light would not go off. Then sometimes while I was driving it would randomly go off and on. I think the problem is that the plug at the end of the brake handle (inside the console) might be touching metal. I had metal touching down there. I wrapped electric tape around it and it stopped doing that. This also happened at the same time my alternator was going out.
thx....i'll keep that in mind....but for some reason (maybe IF there was metal touchin...it came off?).....it's back to normal now.....so problem fixed i guess.. :dumbass: ...thx anyways
 

·
Viva el iPod
Joined
·
1,232 Posts
erixpulsar said:
thx....i'll keep that in mind....but for some reason (maybe IF there was metal touchin...it came off?).....it's back to normal now.....so problem fixed i guess.. :dumbass: ...thx anyways
Doesn't mean it won't come back just as randomily.
 

·
Whore Slut Bitch
Joined
·
464 Posts
This is a problem that I had with my pulsar too... the light would go randomly on and off as you say, which didn't bother me much. You might try reseting the switch in the kick panel (granted you have one), or cleaning the switch, as was mentioned. Kinda funny how that works, I never understood how that could possibly happen.
 

·
LUCKY SLIDES 2 2/25/06
Joined
·
504 Posts
actually make sure you have brake fluid in the resovior because i couldnt figure out why my e-brake light kept comin on either because it would randomly when i was driving and the e-brake was down and then i checked the fluid and it was super low but this is just a suggestion

Don
 

·
Registered
Joined
·
77 Posts
Discussion Starter #10
sunnydet90 said:
actually make sure you have brake fluid in the resovior because i couldnt figure out why my e-brake light kept comin on either because it would randomly when i was driving and the e-brake was down and then i checked the fluid and it was super low but this is just a suggestion

Don
uhh...yea i got plenty of fluid......but what does THAT have to do w/ the ebrake?.....ebrake's a cable system...doesn't use fluid..
 

·
Registered
Joined
·
193 Posts
erixpulsar said:
uhh...yea i got plenty of fluid......but what does THAT have to do w/ the ebrake?.....ebrake's a cable system...doesn't use fluid..
The brake light isn't just for showing that the e-brake is engaged. It will also come on if you're low on brake fluid.
 
1 - 11 of 11 Posts
Top