Nissan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
as the title says i'm having some trouble geting the heat pumpin in my 87 b12. first it was the theromstat changed it then it was good but about a week later the upper rad hose blew out and now i have a massive air lock in my cooling system causing my heat to either suck of actually blow cold (and today its -35°c) so that doesn't help me to much.... i've done some searching but none of the threads that i found explained how to actually bleed the cooling system on a e16 engine (carb) any input would be greatly appriciated thanks in advance
 

·
Ex-mod/nissan guru
Joined
·
2,136 Posts
simple solution here ... park the car with the front end higher ... to get the rad cap over the height of the thermostat... (at worst jack the front end)... get that rad cap off, run the engine till it get up to temp while filling it till no bubble come out anymore.
Make sure you put the heater totaly to the hot, and fan working full also, this will help get rid of the air that might have got into the heating system also. this takes about 5 minute to do.
 

·
Registered
Joined
·
2,376 Posts
i was just going to add....i lived up a hill somewhat....so whenever i messed with cooling systems (regardless of what car) I'd drive around town until the thermostat would open up then when i come back just take my time going up the hill, all the air would work its way up the radiator...then when i got home i'd relieve coolant pressure(be careful doing that...actually don't do it, i don't want someones 3rd degree burns being my fault ).
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
thanks for the tips everyone last night i drove around without the rad cap on and it actually got upto normal temp for the first time in a couple days... parked on a hill i'm not sure if it was steep enough or not but i was outside watching bubbles come up for a while went a looked at the temp gauge and it was back down to 1/4 i dunno about that so i topped it up again ran it at about 2-2500rpm took another 5 minutes to get upto temp again then i just got to cold and said screw it.... so its still locked up pretty solid
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
i forgot to add i was thinking maybe the new thermostat i put in is locked open because the temp gauge only goes upto 1/4-3/8 but last night without the rad cap on it got upto normal temp i'm guessing thats just because of the air lock
 

·
Ex-mod/nissan guru
Joined
·
2,136 Posts
never put a fail safe into an E-serie engine : trust me !!... your better buying yourself an Oh Henry with the 2$ difference ... that engine will not heat over the 1/4 with a locked thermostat open.
 

·
Registered
Joined
·
2,376 Posts
i just wanted to add for anyone who ever runs a search....this can also be a cause of bad gas mileage. Not coming up to temp can cost a few mpg.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #9
YES I SECOND THAT!!!!!!!!! my gas millage has seriously dropped and it was the same before i changed the thermostat.... after i changed the thermostat it was way better on gas (should've changed the hose too it said nissan on it so i'm guessing its the same age as the car), tomorrow i'm going to a heated garage so that my engine can actually get upto normal temp seeing as how its -30 to -40°c outside i'm sure that isn't helping me very much... hopefully it works out good because no heat+winter= geting a very bad cold :(
 
1 - 9 of 9 Posts
Top