Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello & thanks for Checking this Post.
I went to start My Hardbody Yesterday & this morning. the Engine Ticked/Knocked for about the first 1-3 seconds then it Quits. Smooths out fine. The Oil Light Appears when this takes Place & then Disapears after it quits. My first thought is Oil Pump Needs Replaced b/c after the engine gets oil up top it quits So I don't think its a bad lifter/valve. Its when I leave it set over night & go out the next Morning when it does it after all the oil goes back down to the pan.

anyone having this problem or would agree that its the Oil Pump? Let me know
 

·
Registered
Joined
·
34 Posts
If this is a 4cyl, the timing chain is famous for rattling when they first start up. Depending on what year of 4cyl, you may need to replace the timing chain and guides. 1990 thru 1993 all had plastic guides that eventually break, allowing the chain to rub the timing cover. Sometime during the 1994 model year, this guide was redesigned eliminating the problem.
Regardless of model year, always use a high quality oil filter with an anti-drainback valve (such as Wix). This will usually solve the chain rattle on startup.
If you have a 1994 or older 4cyl truck, have the timing chain and guides inspected and/or replaced as needed. The service parts for the early models have been replaced with the later design, thereby preventing a repeat of the issue.
 

·
Registered
Joined
·
207 Posts
...the engine rattles or knocks when starting? If its knocking, that could be bad...if its rattling, that is normal. Like rouge said, its just the tensioner not tightening up until you get some oil pressure. Not the oil pump...
 
1 - 3 of 3 Posts
Top