Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
313 Posts
Discussion Starter #1
Ok Guy's I ended up swapping my engine and tranny out with a 40k wreck combo. The problem with cold start still remains? At first I was thinking that it was the engine stat that tells the cpu that it needs more fuel. But now I am beginning to thing that the fuel pump is is tired? in fact I am leaning hard towards this being my issue. The car runs good once it's started but the low range and hill climbing are abysmal! Anyone else have a weak fuel pump problem in the past that caused these problems???
 

·
Registered
Joined
·
313 Posts
Discussion Starter #2
OK I have figured out a couple of issues but the hard start thing is still with me? What is happening here? I real puzzeled? The engine is fairly new and I can't emagine the sensor being bad alredy?
 

·
Sup Mod keeping the peace
Joined
·
7,042 Posts
Sounds like a fuel delivery problem. Install a temporary fuel pressure gauge at the output of the fuel filter to check the pressure. Could also be a problem with the fuel pressure regulator.

Have you changed the following:
- spark plugs
- air filter
- fuel filter
 

·
Registered
Joined
·
313 Posts
Discussion Starter #4
Yea I think it is a delivery issue,I think what is happening here is the gas is draining back to the tank over night causing the rough start conditions. It starts good every time after that. There seems to be a flat spot here and there when accelerating so I think the fuel pump needs to be changed. The engine has 47 k on it so the regulater should be alright. I pulled the pump the other day and the screen was plugged up with crap I cleaned it up and put it back in and it seems better but I still have the check valve issues...
 
1 - 4 of 4 Posts
Top