Nissan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My gas and temperature gauges are not working. Is this a common problem? Do these two gauges run on the same power supply? Is the gauge cluster a pain to pull?
 

·
Registered
Joined
·
21 Posts
My Sentra had the same problem. Check all your fuses meticulously.
If it's not the fuses, it's most likely the regulator behind your instrument
cluster. Isn't too hard to get to...like 14 screws or something like that.
 

·
Registered
Joined
·
34 Posts
Yeah mine has the same issue. It's not the fuses. It's the regulator like he said. Easy to get everything off, just when pulling the bezel off, make sur to unplug everything from behind it first or you'll break shit like I did. From what I hear this is a semi-common issue but not alot of people know about that little regulator on the back. Which is nothing more then an SRC transistor, a capacitor, and a resistor. Some are encased in housing and epoxy filled though.
 

·
Registered
Joined
·
34 Posts
Perhaps since alot of us know the issue is the regulator, this should be stickied?

I will go ahead and add a bit more information on it right now too. 1988 model Sentra's use a different regulator then pre-88 and post-88 models. From what I have seen at the JY, the post-88 regulators are found up through at least. Maybe further. It is possible to adapt a post-88 to an 88, but it doesn't work for very long. The ones pre-88 are not going to be able to be adapted, I'm not sure how far back these go, but they do go at least as far back as 85. I've not been able to check anything older. In addition, if I remember correctly from the JY the older Stanza's have the same regulators as pre-88 Sentra's. The big thing here is 88 has it's own(which sucks for me as that is what I have, but I finally found an 88 Sentra at the JY, just had to drive to hell and back to get it), but my gauges are working fine now.

I propose with this thread being straight and to the point, and with this added info and hopefully some confirmations and corrections as needed, that this topic now be stickied. How about it mods?
 

·
Registered
Joined
·
61 Posts
Paid 60 bucks at the stealership for a new one after going thru 1 from the bone yard and purchasing another from a forum user. Tried to get a third from the bone yard but the Sentras that they had left already had the clusters ripped out.
 

·
Registered
Joined
·
12 Posts
i had the same problem a while ago, i change my REGULATOR and it works fine now.
mine wasn't to hard to change, jus about 5 screws to remove.....1990 sentra (b12)
 

·
Registered
Joined
·
1,266 Posts
there are actually 3 different voltage regulators depending on the gauge cluster, one looks like a transistor ( which the parts manager at the nissan dealer back home never saw before), the 2nd one is a black part with a heatsink, the 3rd is a smooth surface silver color. My car of course took the 1st one the dealer never saw before ( of course!!)
 
1 - 9 of 9 Posts
Top