Nissan Forum banner

1 - 5 of 5 Posts

·
Dan the car meet man
Joined
·
404 Posts
Discussion Starter #1 (Edited)
I have the GA16DE and my car's ecu keeps sending the EGR code. Its a 1994.5 sentra and I think it has OBD-1. Will my car pass the emissions with CAI, Random Tech. Cat, and 2" mandrel exhaust? I have to do the inspection this month. Here's a couple links about the details of the emissions:

http://ci.fort-worth.tx.us/DEM/air_im.htm
http://www.txdps.state.tx.us/vi/act.htm

I don't have very much money to spend on a full EGR system but I've tried checking some of the hoses but I'm not exactly sure which ones to check and what exactly to do. Any help would be greatly appreciated!

Here are some of the symptoms / details:
1. Check Engine Light Comes on -
This happens after running the car for over 3 minutes.
Comes on when you drive the car on the highway or road
at the same RPM.
2. Gas mileage is not as good as 2 years ago
3. Lacks Engine response when the check engine light is on
4. Check Engine Light does not stay on all the time
5. Engine has 20,000 Miles, car & systems have 177,000 miles
 

·
Tuner/Mechanic
Joined
·
266 Posts
whats up dan, check the bottom of the egr valve...the ufo looking thing to the right of the throttle body looking from the intake side...the hose is very prone to cracking. take it off and check it out, this caused my car to do the EXACT same thing...mine's a 94 xe. anyway, let me know how it goes.
 

·
Dan the car meet man
Joined
·
404 Posts
Discussion Starter #3
I found this tiny 1/8" hose that goes to nothing. It looks like it goes to the tiny little air box between the MAF / TB. From what I heard it wasn't needed so that's why the HS CAI's only have 2 hose spots. Could this be causing the problem? It rarely comes on during accleration or city driving, only crusing. Should I worry about this and just clear the ecu and immediately go to the inspection place?
 

·
Tuner/Mechanic
Joined
·
266 Posts
if its the one i'm thinking of, then it goes to the other ufo looking thing to the left of it. its like not even 2 inches long and does a 90 degree bend? this is the one i'm talking about.
 

·
Dan the car meet man
Joined
·
404 Posts
Discussion Starter #5
Hmm.. I'm not sure. This little 1/4" diameter hose has about 1-1/2 ft of slack. It went on the bottom of the mid-pipe from a little black box. I had this problem even before it was disconnected by itself. Please give me more details so I can just go in and double check. There's soooo many black hoses back there!
 
1 - 5 of 5 Posts
Top