Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi guys, I am new to this forum and in need of some assistance.

I recently performed a swap form a GA15 to GA16 on my sunny B14. This involved changing the engine, transmission, brain and harness.The engine is the B14 plastic cover version (http://upload.wikimedia.org/wikipedia/commons/a/a4/Nissan_GA16DE.jpg).

Problems.....

The problem is the the engine wouldn't start because the fuel pump does not engage with the GA16 ECU (ZW). Upon further inspection it seems the fuel pump pin doesn't work. If I take the original GA15 brain and plug it into the GA16 harness, the GA16 engine starts and idles. Fearing the GA16 ECU was faulty I barely managed to get a replacement as these engines are rare where I come from. However the replacement ECU I got was from the metal cover B13 version. The ecu has the number 47 when compared to the B14 version which read ZW.
Now the engine starts and seems to work good vtc and all on the B13 ECU but the question is, are there any major difference in these ECUs? Actually is there any major difference in the B13 and B14 version of the engine, internals, sensors etc.


Second problem....
I have been running the car for about 3 months since the swap and ever since I have had a loud sucking noise coming somewhere from the intake manifold. I was assuming that I had an air leak somewhere because I would sometimes get erratic idling or the engine would "race" while driving. Consequently I have had terrible gas mileage because of this.
I inspected all hoses, removed the intake manifold, throttle body and inspected for cracks. Found nothing, resealed and mounted everything back up. And well the problem still exists.
Now I have noticed that adjusting the air screw on the manifold seems to dampen the sucking noise a bit but not get rid of it. Any ideas on the cause of this?


Third problem....
My AC button doesn't work, thermostat doesn't trip off. The AC works until the point where the evaporator "freezes". I believe I can probably sort this one out as some research showed there were some 1.6 specific wiring for the AC.
 

·
Registered
Joined
·
6 Posts
I own a Nissan 200sx with a ga16de. It's always ran brilliantly dispite how much I've put it through. I only once messed with any of the factory adjustments having to do with the idle and it majorly caused it to have a idle that moved from 500 rpm too 1500 rpm and it revved when I was driving without my assistance. I suggest you take it in and get it properly tuned. It's truely a beast of a little engine.
 

·
Registered
Joined
·
3,194 Posts
The O/P hasn't logged in in a little over 4 years.
Knock knock...
 

·
Registered
Joined
·
1 Posts
Hi guys, I am new to this forum and in need of some assistance.

I recently performed a swap form a GA15 to GA16 on my sunny B14. This involved changing the engine, transmission, brain and harness.The engine is the B14 plastic cover version (http://upload.wikimedia.org/wikipedia/commons/a/a4/Nissan_GA16DE.jpg).

Problems.....

The problem is the the engine wouldn't start because the fuel pump does not engage with the GA16 ECU (ZW). Upon further inspection it seems the fuel pump pin doesn't work. If I take the original GA15 brain and plug it into the GA16 harness, the GA16 engine starts and idles. Fearing the GA16 ECU was faulty I barely managed to get a replacement as these engines are rare where I come from. However the replacement ECU I got was from the metal cover B13 version. The ecu has the number 47 when compared to the B14 version which read ZW.
Now the engine starts and seems to work good vtc and all on the B13 ECU but the question is, are there any major difference in these ECUs? Actually is there any major difference in the B13 and B14 version of the engine, internals, sensors etc.


Second problem....
I have been running the car for about 3 months since the swap and ever since I have had a loud sucking noise coming somewhere from the intake manifold. I was assuming that I had an air leak somewhere because I would sometimes get erratic idling or the engine would "race" while driving. Consequently I have had terrible gas mileage because of this.
I inspected all hoses, removed the intake manifold, throttle body and inspected for cracks. Found nothing, resealed and mounted everything back up. And well the problem still exists.
Now I have noticed that adjusting the air screw on the manifold seems to dampen the sucking noise a bit but not get rid of it. Any ideas on the cause of this?


Third problem....
My AC button doesn't work, thermostat doesn't trip off. The AC works until the point where the evaporator "freezes". I believe I can probably sort this one out as some research showed there were some 1.6 specific wiring for the AC.
  • I upgraded my b14 nissan from Ga 15 to Ga 16de. It's plug and play and it runs smooth. The only modification done to the engine was maintain the intake manifold for ga 15 on the ga16.
 

·
Sup Mod keeping the peace
Joined
·
6,745 Posts
hello nissan boy... does anyone have a wiring diagram for nissan b12 sentra 2 door? thanks. ride safe to all.
With a question like yours, it's best to start a new thread. However your best bet for getting a wiring diagram is to download an FSM (Factory Service Manual) for your vehicle from any of these web sites:

 
1 - 6 of 6 Posts
Top