Nissan Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have a 1995 240sx, and it has been swapped with an sr20det and transmission both from an s14 silvia. There are some mechanical issues but nothing i cant fix myself once the weather gets better. The main issue with the car right now is the alternator. However the other issues are with the exterior lighting. The turn signals dont work, but the four way flashers will turn on when i hit the hazard light button. So the lights themselves work but for some reason not when theyre triggered individually. On top of that, the high beams work (both when i turn them on by snapping the stalk forward and when i hold it back for to momentarily turn them on), the daytime running lights also work but the low beams dont turn on at all. Also, if the high beams are on and i try to turn the low beams on, the high beams go out, even when the stalk is in the on position. These issues were around before the alternator went and the other electrical components work fine (speakers, head unit, speedo, etc) so I want to assume its either a wiring issue or there are some blown fuses. The problem is ive been having a really hard time finding a diagram for the interior fuse box (ive found one for the sr20det). If anyone knows what else could be causing the issue id love to hear ideas, and Id also love it if someone could send over a diagram of the interior fuse box because mine is missing the cover that im assuming would have a diagram on it. Thanks in advance
 
1 - 1 of 1 Posts
Top