Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter #1
Is it true that overfilling your fuel tank in an HB will fry that evap pressure sensor??? Code P0450?

I found that the plastic tee that tied into the pressure sensor was broken, so, I replaced it with a homemade mix of brass fittings and new tubes.

Now that the system is closed and pressurized again, i am still getting the code despite repeated deletings.

Any help is appreciated!!!
 

·
Registered
Joined
·
2,220 Posts
dont think so, it would take an awful lot of fuel to get through the lines to the sensor, IMO.

most common cause of that fault is the gas cap not tight. be sure to get at least 3 clicks when putting gas cap back on, the next common fault is the canister above the spare tire, I swapped mine with one from a j/y 2yrs ago, has been back.
 

·
Registered
Joined
·
160 Posts
Discussion Starter #3
Well, my local pick n pull felt like crushing all its trucks in a twisted form of spring cleaning...

Gas cap is a relatively new locking unit, tried putting some vaseline on the seal which made no improvement, will go to the next possible one, canister, and sensor.

Thanks.
 

·
Registered
Joined
·
706 Posts
I know this is common in the 95-03 Maximas but the evap charcaol canister is less the 18" from the the gas filler cap. so I'm a little shy to overfilling my HB. Realistically my canister is at about the same level as the gas cap but it's 12 feet away via the line. So it's not a factor on mine. Now those gas caps can cause a code due to poor sealing and a little vaseline on the oring will cure that problem, Or a new cap!
 
1 - 6 of 6 Posts
Top