Nissan Forum banner

1 - 9 of 9 Posts
D

·
Guest
Joined
·
0 Posts
Discussion Starter #1
my check engine light was on, i took it to Autozone, they checked my codes, and I had a P0100, P0110, P0115, P1550 (not necessarily in that order).

The descriptions are:
P0100: Mass or volume air flow circuit malfunction
P0110: IAT circuit malfunction
P0115: Engine coolant temperature circuit malfunction
P1550: PSPS out of self test range


I dunno what to do. All I've done to my engine was do a ghetto airbox trick. That involved flipping the MAF around, which kinda stretched the wires a bit. I'm GUESSING that a wire got stretched too far and maybe unplugged a tad (?) and caused all this but I still don't know how to resolve that.

HELP!!!
oh yeah my dad thinks that if I put the bottom of the airbox back on and restore it back to normal that everything will be fine and the light will go off. I don't think he's right, and if you don't think he's right make sure to say he's not right so I can show him that lots of people are sure he's not right.....thanks
 

·
PB JELLY TIME!
Joined
·
1,484 Posts
Was this post for us to help you get your car working fine again, or just a simple answer so you can run to your dad and tell him "I told you so!" ??
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #3
the purpose was 98% to get my engine light off and everything perfectly fine and 2% "i told you so"
 

·
Boost anyone?
Joined
·
1,625 Posts
Yeah i know what you mean. I took off the stock box and added the MAF adapter and CP filter. It started to make the hissing noise and he said he didnt like that sound and to put it back the way it was. I did some searching on here and these people told me to mess with the idle. I did and i lowered the hissing to almost nothing. I still have the little growl and more space in the engine bay. I showed him up. I love to prove him wrong but at the same time i know he's proud of me because i took it within myself to find the answer to my problems.
 

·
Tuner/Mechanic
Joined
·
266 Posts
great. to answer your question yes your dad is wrong. it is a wire stretched too far and become unplugged. just look at the plug on the side of the maf and see which one is out. you can take the little rubber boot thing off easily and check. and it sounds like your idle is a little off. my 2cents.
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #6
fixed

haha this is kind of funny. Yesterday just to try it out, I messed around with the wires going into the MAF and tried pushing them in and all to try to get things right. So I start the car and darn the engine light is STILL on. Poop. Then last night I come back home and put my sentra in the garage and just so happen to forget to turn my headlights off (first time, last time). I get up this morning and my battery is dead. I jump the car and ***VOILA*** my light is off! I'd forgotten to unplug the battery to reset the ECU after I messed with the wiring.

Now I'm just hoping the light doesn't go back on after a few miles of driving.
 

·
Registered
Joined
·
351 Posts
My question is how do you get all these codes at once? Autozone used Consult? I wonder which code it would give you, if you did it the manual way on the back of ECU.
I bet you would get only P0100: Mass or volume air flow circuit malfunction which is the correct one.
What good is all 4 codes, that doesn't help to pinpoint the problem.
 

·
Cone Dodger
Joined
·
3,093 Posts
fault codes......

could be a harness fault for all those codes to set in, but i don't know, there was a bulletin to check for the harness that goes though an uninsulated "portal" on the engine bay, i think it's on the left.....check it out.......
 
1 - 9 of 9 Posts
Top