Nissan Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
After a pretty extensive search on the forums, I didn't quite find what I was looking for. I noticed today while letting my car warm up and cleaning the windows off my car has a few problems. After it warms up the idle will rise up to just below 2000 RPMS then drop down almost immediately to just under 1500 RPMS, then climbs back up again taking only just a few seconds.

The other problem that I have with it, is that my acceleration completely sucks! I know that its only a 1.6 so it isn't all that great anyway, but I have problems after shifting into third gear even increasing speed with the pedal on the floor, which i know isn't supposed to happen.

Recently, while fighting other troubles on my quest to 'complete' my motorswap, I've done all sorts of stuff. During my troublshooting, I swapped the rotor, cap, wires and plugs, fuel filter, cleaned the iac valve, throttle body, and TPS contacts.

I currently do not have a check engine light on, nor do I have any trouble codes that exsist. From searching the forums, I've come up with three possible answers/solutions. MAF, exhaust, and timing. Just wondered if anyone had any clue ins or related past problems that could shine some light on this, or know of anything that connects the two and solves the problem!! :)
 

· Registered
Joined
·
145 Posts
Discussion Starter · #3 ·
Timed the car out a lil' while ago and it was off. Set the timing on it and it does alot better. Still not perfect, but a good start.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top