Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
guys, whenever i race/rev my engine up, that is when idle, step on the accelerator, i hear a knocking sound inside the engine? sound appears when the gas is applied abruptly..... but when it is slowly applied no knocking sound is heard.....

what do you think could be causing the problem? my engine is a qg13de.....
could it be the maf, the timing, or what?.....

hope anyone can help.....

thanks to all......
 

·
i pwn your mom
Joined
·
5,439 Posts
it might be the type of gas you are running causing yoru knock sensor to go off... upgrade your fuel and check your timing to see if that helps
 

·
Registered
Joined
·
52 Posts
i c u got the sentra, i hope u took it in for that dam recall, when the o2 sensor would failed (also something failed), and some peoples cars would seize up on them, "no good". mine was making that same knocking sound i took it back to the dealer, and he said the cat failed, fused all the sht on the inside, and was causing back burn, got half a new engine for that sht. and some what of a new exhaust stream. damm cats, but mag cloride rusted half my under belly any way.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
i took it back during the recall, everything was fine, i'm also using a 95 octane gasoline for 19 months with no problem, just recently, after my car was fixed, caused of an accident but no damage to the engine bay, except for the headlight and bumper, i noticed that when you revved it abruptly, there is a knock noise, i cleaned the MAF with contact cleaner and everythings back to normal........ whu... good thing is was only the dirty MAF that caused the problem....
 

·
i pwn your mom
Joined
·
5,439 Posts
i would get your timing checked, cuz if it is advanced too much it iwll knock..
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
with regards to the timing, the timing is in good condition, as systemy engine is a distributorless timing m it is most unlikely that the timing be a problem. engine is running in tip top shape now....... i keep getting the answers that the ecu controls the timing of the QG engines..... it is most unlikely to get out of tune..... unless some sensors are malfunctioning..... the MAF was the cause of the knocking....... i also resetted the ecu memory so that everything was at default and the engine relearned everything..... engine is now back to its optimum performance.........

thank you for all the inputs.......
 
1 - 6 of 6 Posts
Top