Nissan Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
361 Posts
Discussion Starter · #1 ·
First off.. before i touched anything inside the engine bay.. perhaps my elbow might've moved something.. i don't know.. but the door lights.. the radio.. tachometer and speedometer do not work or turn on! But the rest of the lights do.. headlights.. but no turn signal and no brake lights!

Any tips on what it could be..

Thank you
 

·
Registered
Joined
·
114 Posts
Uni said:
First off.. before i touched anything inside the engine bay.. perhaps my elbow might've moved something.. i don't know.. but the door lights.. the radio.. tachometer and speedometer do not work or turn on! But the rest of the lights do.. headlights.. but no turn signal and no brake lights!

Any tips on what it could be..

Thank you
A power lead has been grounded out. Check your fuses and replace the blown one. Then start looking for the short, starting near wherever you were when this happened. Just take your time and be thorough and you should find it.
 

·
Registered
Joined
·
361 Posts
Discussion Starter · #3 ·
94econobox said:
A power lead has been grounded out. Check your fuses and replace the blown one. Then start looking for the short, starting near wherever you were when this happened. Just take your time and be thorough and you should find it.
Thanks for the tip.. how do i check for teh short? i think that i had the car on jacks at the time.. would that have anything to do with it..?? I see there are fuses near the battery and in front of the driver side on ther right where the hood latch opener is..

appreciated
 

·
Registered
Joined
·
100 Posts
Same thing happened to me when i installed my headers. You blew your battery fuse. The fuse is under the hood.
 
1 - 7 of 7 Posts
Top