Nissan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I am having a real serious problem with my car (85' 300Zx turbo). At first, it was just the front left high beam not getting power. Now, the tail lights are out, the dashlights are out, the parking lights are out, the front right low beam is out, the front left fog light is out, the reverse lights are out, and the front left high beam is still out. We checked all of the bulbs and know that they all are good. We also checked the fuses and relays, and they are all good too. I'm clueless... any ideas?
 

·
Banned
Joined
·
3,785 Posts
Wiring problems are far and few between on most cars. I also have an 85 and the only problem I have is with the high beams. If you can absolutely rule out the fuses and relays, next step is to check the headlight switch itself. It's probably old enough that it should just be replaced if anything is in doubt. Next step after that would be to check wiring, but thats a huge pain.
 

·
Banned
Joined
·
3,554 Posts
On the column of course.. Left little stick thing
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7 (Edited)
Ok, I took out the headlight switch and cleaned out some corrosion. I put it back in, but the only difference the corrosion made was the front right low beam came back on. So while I was trying something else out I came across some more relays, ones I have not seen or tested yet. This could mean that I have not found all of the relays. So I need to know where the relays are for the lights and if there are other fuses outside the fuse box so I can test them. thanks
 

·
Banned
Joined
·
3,785 Posts
Theres 2 boxes of relays under the hood, on the passenger side, and a box of fusible links back by the battery, same side. At least on mine, that's how it's laid out.
As far as the light switch itself is concerned, sometimes replacement is the only way to solve issues. There may be other things wrong that you can't see.
 
1 - 8 of 8 Posts
Top