Nissan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 1989 300zx tt and When i did the recent engine upgrade and swop I ruined one of the EGT sensors I was wondering if anyone would have a replacement part number and ideas on where else I could get these cause the nissan dealer in my area is a little less then helpfull with my build thanks!

Oh and for those of you who think it doesnt have them its a RHD japanesse model and I does. everythign seems to be the same as a 92 or so. thanks
 

·
Power FC Z32
Joined
·
2,147 Posts
If you your car came from California then you need a EGR and not a EGT. There are no EGT's on the z32. Also no JSpec engines have ERGs. What exactly did you break? Can you post a pic?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
The car came direct from japan. Its a 1989 vg30dett 300zx the egt sensors are located after the converters in the exhaust system the wires run up into the floor and under the carpet. there are two of them one in each pipe. I had to heat it to get the pipes off the car when i did the mods and it ruined it id prefer to reaplace both of them if they arent that expensive.
 

·
Power FC Z32
Joined
·
2,147 Posts
The car came direct from japan. Its a 1989 vg30dett 300zx the egt sensors are located after the converters in the exhaust system the wires run up into the floor and under the carpet. there are two of them one in each pipe. I had to heat it to get the pipes off the car when i did the mods and it ruined it id prefer to reaplace both of them if they arent that expensive.

Are you talking about the O2 sensors located on each downpipe?
 

·
Registered
Joined
·
19 Posts
Hey,
I also have those on my 1993 RHD Z32 TT. I'm pretty sure they are not O2 Sensors, cuz they are a prong, and not a O2 style sensor, I'm doing a mid pipe replacement, and the new mid pipes do not have a place for them, so i am wondering what i could do with them, Either weld in bungs or just take them off or what? lol
 

·
Registered
Joined
·
717 Posts
If you're talking about the tubes after the Precats then those are the AIV's. The EGT on USDM models, only in California are on the EGR tube. You can do the resistor trick to turn the CEL off if that's the problem your having.

I'm starting to think I need to get ahold of a full JSpec Z to know more about the little differences.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
PLEASE STOP THINKING THESE ARE THE O2 SENSORS OR THE AIV'S THESE ARE DEFFINATELY EXHAUST GAS TEMPERATURE SENSORS. I work in the parts industry and have seen enough of these on deisel applications and have sold them to many race enthusiasts for exhaust probes before to know these are deffinately exhaust temp probes. I just dont have any suppliers that have access even to factory replacements for these cars. I would really like to replace them with factory units as it came with cause then I dont have to bucher the wirring on them to splice in aftermarket probes.
 

·
Registered
Joined
·
19 Posts
already did the AIV deletion a little while ago. i think the Jspec models are different like that! lol I'm just wondering if i have to have them put back in the exhasut for the car to run properly (So the engine light won't come on) or if i can just unclip them? thanks for all the help!
 

·
Registered
Joined
·
717 Posts
already did the AIV deletion a little while ago. i think the Jspec models are different like that! lol I'm just wondering if i have to have them put back in the exhasut for the car to run properly (So the engine light won't come on) or if i can just unclip them? thanks for all the help!
If they are EGT's then just do the resistor trick to kill the CEL. If they're after the precats then that would answer why I haven't ever seen them cause The JDM motors I have gotten have the pipes off after the precats.
 
1 - 9 of 9 Posts
Top