Nissan Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I have two problems that are dependent on which EEPROM is in.

I have two EEPORMs, if the one that is set for a richer mixture is in the car cannot idle steady. The idle constantly searches between 500 and 1500RPM and occasionally will die. When driving it, it is running great.

If the EEPROM that is set for a leaner mixture is in the car, the car stutters and doesn't wat to go above 2500rpm while under load. I am assuming that it is in safe mode.

The ECu was kicking out the knock sensor code. After fixing the knock sensor the car went right back to doing the same thing.

Any help on this would be greatly appreciated.
 

·
Power FC Z32
Joined
·
2,147 Posts
Idle is a closed loop function so you most likely have a problem with a sensor ( O2's, water, fuel, or MAS) Have you done a ECU diagnostics?
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
Ecu diag is now saying code 55. I have the richer chip in the car now. Disconnecting O2 does nothing, I figure that if MAS was the problem it would run rough while driving, I also checked all of the rest of the thing in that part of the troubleshooting in the manual. TPS, injectors, and spark plugs. Messing with the water temp connector did nothing. My last guesses are that there is a problem with the IAC or the car doesn't like either of the EEPROM's???
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #5 ·
I think that it was JWT, it was flashed before I got the car. I just spoke to them (JWT) and they said that I had a really old chip and needed the "low speed drivability kit." They also said that the chip that I was told was the lean chip is a stock chip. Do you know how the low speed drivability kit connects?
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #7 ·
Yes. I am going to try to run a secondary hose to the passenger side intake plumbing and see if that does it tonight.
 

·
Registered
Joined
·
1 Posts
Further Explain????

I Have a feeling that I am having the same problem with my car. It's had a bunch of upgrades, but the only thing that I can see that wasn't done up to spec was the low speed driveability kit. I have seen a couple of places that have showed how to do it including JWT website but the pics of them are not the best and don't explain the hosing very well. Could you by chance take some pics and send them my way so that I can see what you did and maybe I can try it???

My '90 300zx tt is fine when you start it but, but when it warms up and the the comp kicks in then the throttle keeps going from like 500 - 15-20k up and down up and down. It will stop hunting if i rev to about 4000-5000 then it runs string again. ANY INPUT WOULD REALLY BE AWESOME. THANKS
 

·
Registered
Joined
·
8 Posts
Looking for a ECU/ECM

Looking for a ECU/ECM, for a Nissan Sentra 2001 1.8L, automatic transmission.

ECU/ECM Identification#: 237105M105

Looked all over the place and only the dealer has it, they want 1200$!

Can anyone help?

Thanks!
 
1 - 11 of 11 Posts
Top