Nissan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
110 Posts
I have a problem with my e16i. Whan i leave from a light it doesn't pick up that fast but once i'm cruising at 40 and step at it it flys all the way to 60. But if i go faster then 60 it shakes. I think it's a misfire sort of kickin.

I have changed:
1.fuel filter
2.spark plugs
3.cap
4.rotor
5.Battery just bought it yesterday interstate 120 canadien

And i also have a set og NGK spark plug wires and i'm planning on changing the oxygen sensor

What do you guys think the problem is?
 

·
Still moderating..sorta
Joined
·
1,324 Posts
Sounds sorta like my problem. And you have changed all the things I changed too. hmmm....I have no idea. If you do figure it out please tell me.
 

·
Registered
Joined
·
110 Posts
Discussion Starter #3
yesterday i was driving it and ot one point i went at 65 and it started jerking. I think that the problem is the spark plugs Ricebox. When i change them i'm gong to tell you.Also i plan on changing the oxygen sensor because it's old the car says it has 118000km mybe even more it's kind of old. I think that the sensor is ruined and it doesn't send the right readings ta the computer and the doesn't accelerate good when i change that i'll let you know how it's driving

I also plan on puttinh a new thermostat that opens up at a lower temp for a cooler engine and more power
 

·
Still moderating..sorta
Joined
·
1,324 Posts
make sure you gap your sparkplugs properly after buying them
 

·
Registered
Joined
·
110 Posts
Discussion Starter #5
Ricebox i just changed my wires with brand new NGK's and car kicks some serious ass right now. I got it over 60 which i never did before. I wonder how it will feel when i change the oxygen sensor
 

·
Still moderating..sorta
Joined
·
1,324 Posts
That's great that you solved the problem. You can check to make sure the O2 sensor is working by checking the ECU for codes.
 

·
Registered
Joined
·
110 Posts
Discussion Starter #7
there's no point the car has 118000Km and maybe even more the guy who had the car before my dad used it as a delivery car. And to check the 02 sensor i'll have to plug in a computer and pay someone. I'll just replace it a brand new one from canadien tire is 40 smacks.
In the other threat i wrote about the 8.8mm wires. the car drives better compared to when i had those a 8.8mm on .
 

·
Still moderating..sorta
Joined
·
1,324 Posts
mustang302 said:
there's no point the car has 118000Km and maybe even more the guy who had the car before my dad used it as a delivery car. And to check the 02 sensor i'll have to plug in a computer and pay someone. I'll just replace it a brand new one from canadien tire is 40 smacks.
In the other threat i wrote about the 8.8mm wires. the car drives better compared to when i had those a 8.8mm on .
You can check the computer for free. All the codes and instructions are listed in the Haynes manual, which you should buy anyways.
 

·
Registered
Joined
·
11 Posts
mustang302 said:
I have a problem with my e16i. Whan i leave from a light it doesn't pick up that fast but once i'm cruising at 40 and step at it it flys all the way to 60. But if i go faster then 60 it shakes. I think it's a misfire sort of kickin.

I have changed:
1.fuel filter
2.spark plugs
3.cap
4.rotor
5.Battery just bought it yesterday interstate 120 canadien

And i also have a set og NGK spark plug wires and i'm planning on changing the oxygen sensor

What do you guys think the problem is?
Hey Pal!

I used to have an 87 Sentra Hatchback w/ same engine!
It seemed to slighly hestitate at first, then run like a top!
When I bought my Sentra, someone had already blown the head gasket on it!! :eek:
Check compression!
 
1 - 10 of 10 Posts
Top