Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Have had the MIL light constantly on. Dealer read out the P1320 code and indicated all the Ignition coils needed to be replace. Strange thing is, the car runs perfect 90% of the time, but then it seems to be running on 4 cylinders and the MIL light blinks. Question is, is it normal for a coil to work sometimes or do they experience a complete failure. Before spending big bucks (for me), I want to make sure its not a simple wiring problem (which would be no fun trying to track down).
Any help or advice out there?
 

·
Registered
Joined
·
110 Posts
That is the biggest problem with finding a bad coil. Some times it is fine and other times it will miss.

Look on line to get a new set of coils. Jerry Rome Nissan has a good price. Put "MAXIMA" as a discount code to get additional amount off.

DO it your self and save a lot of money.
 

·
Registered
Joined
·
53 Posts
sdanger said:
Have had the MIL light constantly on. Dealer read out the P1320 code and indicated all the Ignition coils needed to be replace. Strange thing is, the car runs perfect 90% of the time, but then it seems to be running on 4 cylinders and the MIL light blinks. Question is, is it normal for a coil to work sometimes or do they experience a complete failure. Before spending big bucks (for me), I want to make sure its not a simple wiring problem (which would be no fun trying to track down).
Any help or advice out there?
Check the two grounds for the EGI harness by the oil filler cap, I've seen those two 10mm bolts loose cause almost the same problem with the engine lamp flashing.
 

·
Maxima.Org Postwhore
Joined
·
265 Posts
Typically its a coils issue... but Nokturnal might have a point too....

I've never had experience with that myself.... just what I've seen....
 
1 - 4 of 4 Posts
Top