Nissan Forum banner

1 - 8 of 8 Posts

·
Yea, I'm a freak..
Joined
·
560 Posts
Discussion Starter #1
Below are instructions on how to manually retrieve the code for when your MIL/CEL turns on. This works on the Titan / Armada but it's the same process for the 02+ Altima so it will probably work for others as well. Due to the amount of codes I will not list them but feel free to PM me with your code and I will look it up.

HOW TO SWITCH DIAGNOSTIC TEST MODE
NOTE:
- It is better to count the time accurately with a clock.
- It is impossible to switch the diagnostic mode when an accelerator pedal position sensor circuit has a malfunction.
- ECM Always returns to Diagnostic Test Mode I after ignition switch is turned OFF.

How to Set Diagnostic Test Mode II (Self-diagnostic Results)
1. Confirm that accelerator pedal is fully released, turn ignition switch ON and wait 3 seconds.
2. Repeat the following procedure quickly five times within 5 seconds.
a. Fully depress the accelerator pedal.
b. Fully release the accelerator pedal.
3. Wait 7 seconds, fully depress the accelerator pedal and keep it for approx. 10 seconds until the MIL starts
blinking.
4. Fully release the accelerator pedal.

DIAGNOSTIC TEST MODE II — SELF-DIAGNOSTIC RESULTS
In this mode, the DTC and 1st trip DTC are indicated by the number of blinks of the MIL as shown below.
The DTC and 1st trip DTC are displayed at the same time. If the MIL does not illuminate in diagnostic test
mode I (Malfunction warning), all displayed items are 1st trip DTCs. If only one code is displayed when the MIL
illuminates in diagnostic test mode II (SELF-DIAGNOSTIC RESULTS), it is a DTC; if two or more codes are
displayed, they may be either DTCs or 1st trip DTCs. DTC No. is same as that of 1st trip DTC. These unidentified
codes can be identified by using the CONSULT-II or GST.


How to Erase Diagnostic Test Mode II (Self-diagnostic Results)
1. Set ECM in Diagnostic Test Mode II (Self-diagnostic results).
2. Fully depress the accelerator pedal and keep it for more than 10 seconds.
The emission-related diagnostic information has been erased from the backup memory in the ECM.
3. Fully release the accelerator pedal, and confirm the DTC 0000 is displayed.
 

·
Registered
Joined
·
3 Posts
ABS problem

Hi Slurppie,

I can see that may be you can help me with some info. I have codes # C1145, C1102 AND C1104 in a 05 Armada. I want to know if yow have the troubleshooting for these. Please let me know. May be you can fax me.

Rafym

Slurppie said:
Below are instructions on how to manually retrieve the code for when your MIL/CEL turns on. This works on the Titan / Armada but it's the same process for the 02+ Altima so it will probably work for others as well. Due to the amount of codes I will not list them but feel free to PM me with your code and I will look it up.

HOW TO SWITCH DIAGNOSTIC TEST MODE
NOTE:
- It is better to count the time accurately with a clock.
- It is impossible to switch the diagnostic mode when an accelerator pedal position sensor circuit has a malfunction.
- ECM Always returns to Diagnostic Test Mode I after ignition switch is turned OFF.

How to Set Diagnostic Test Mode II (Self-diagnostic Results)
1. Confirm that accelerator pedal is fully released, turn ignition switch ON and wait 3 seconds.
2. Repeat the following procedure quickly five times within 5 seconds.
a. Fully depress the accelerator pedal.
b. Fully release the accelerator pedal.
3. Wait 7 seconds, fully depress the accelerator pedal and keep it for approx. 10 seconds until the MIL starts
blinking.
4. Fully release the accelerator pedal.

DIAGNOSTIC TEST MODE II — SELF-DIAGNOSTIC RESULTS
In this mode, the DTC and 1st trip DTC are indicated by the number of blinks of the MIL as shown below.
The DTC and 1st trip DTC are displayed at the same time. If the MIL does not illuminate in diagnostic test
mode I (Malfunction warning), all displayed items are 1st trip DTCs. If only one code is displayed when the MIL
illuminates in diagnostic test mode II (SELF-DIAGNOSTIC RESULTS), it is a DTC; if two or more codes are
displayed, they may be either DTCs or 1st trip DTCs. DTC No. is same as that of 1st trip DTC. These unidentified
codes can be identified by using the CONSULT-II or GST.


How to Erase Diagnostic Test Mode II (Self-diagnostic Results)
1. Set ECM in Diagnostic Test Mode II (Self-diagnostic results).
2. Fully depress the accelerator pedal and keep it for more than 10 seconds.
The emission-related diagnostic information has been erased from the backup memory in the ECM.
3. Fully release the accelerator pedal, and confirm the DTC 0000 is displayed.
 

·
Yea, I'm a freak..
Joined
·
560 Posts
Discussion Starter #3 (Edited)
Let me look these codes up and I'll report back. Have you by chance changed/added anything (intake, exhaust etc) lately?

***Update*** If these truly are the codes you pulled then I would take your Armada in to the dealer ASAP. You didn't by chance install a stereo or something did you?

RR LH SENSOR 1
[C1102]
Circuit of rear LH wheel sensor is open, shorted or sensor power
voltage is unusual.

FR LH SENSOR 1
[C1104]
Circuit of front LH wheel sensor is open, shorted or sensor power
voltage is unusual.

YAW RATE SENSOR
[C1145]
Yaw rate sensor has generated an error, or yaw rate sensor signal
line is open or shorted.
 

·
Registered
Joined
·
3 Posts
Hi Slurppie,

Thanks for the info. The thing is that the Armada is in the body shop because I hit then right as long the left side. The Body technician said he check all ABS cables and connections and looks well. I am former technician but now I don't have access to Nissan ASIST web. Thats why I need the troubleshoting.

Rafym


Slurppie said:
Let me look these codes up and I'll report back. Have you by chance changed/added anything (intake, exhaust etc) lately?

***Update*** If these truly are the codes you pulled then I would take your Armada in to the dealer ASAP. You didn't by chance install a stereo or something did you?

RR LH SENSOR 1
[C1102]
Circuit of rear LH wheel sensor is open, shorted or sensor power
voltage is unusual.

FR LH SENSOR 1
[C1104]
Circuit of front LH wheel sensor is open, shorted or sensor power
voltage is unusual.

YAW RATE SENSOR
[C1145]
Yaw rate sensor has generated an error, or yaw rate sensor signal
line is open or shorted.
 

·
Registered
Joined
·
1 Posts
Slurppie,

I did the instructions you had on this thread on my 2002 altima that will just shut off while i drive.

The Check engine light just started blinking and i got 10 long, 3 short, 4 short and 10 short blinks from the CEL.

Does that mean P0340?
Is it my crankshaft sensor?

Thanks,
Jan
 
1 - 8 of 8 Posts
Top