Nissan Forum banner

1 - 5 of 5 Posts

·
wont go any faster?
Joined
·
475 Posts
Discussion Starter #1
ok first off i dont kno wut my ignition timing is set at any more ..shop teacher out of town and timing gun is locked up.. but i think im having a detination problem..usualy while cruising around say on the highway, just barely on the gas to keep at one speed it sounds like a knock.. i thought it was an oil pressure problem but when i open the oil cap its shooting out so canceled that out.. could possibly be valve bent but it still runs pretty good..only thing i could think of would be detination.. it sounds like a valve would tap with no oil pressure, as soon as i give it gass it stops.. im only running like 86 octane gas and i had one bottle of octane boost in it.. about to go put some 92 octane and see if it helps any.. can you help me? does it sound like detination
 

·
Mofo
Joined
·
2,225 Posts
It is happening under hard accelleration? Like say your at a complete stop, you take off hard, does it do it then? If so then it is detonation.
Get your timing check asap. If its gonan be a while and you need to fill up before, get the highest grade fuel you can. I really dont like using octane boosters, you just never really know whats in them.
 

·
Powered By hopes & dreams
Joined
·
8,328 Posts
check the spark plugs.

if there are white spots around the electrode and stuff...possibly detonation.

however.....something tells me it's not detonation. anyways pull all the plugs and take pics for us to see.
 

·
wont go any faster?
Joined
·
475 Posts
Discussion Starter #4
no it doesnt do it under hard accelaration and i just put little more than a quarter of gas 93 octane in just waiting for the 86 to burn away..also i got to from an exxon station from wut i heard those are the best quality gas stations.. ill check the plugs tomarow but, i really think its something to do with the timming cause it did it befor, then i retarted it and it ran slow and ate gass bad. so then i advanced it again and it ran fine for a while. then now it started doing it again but louder and now i tried to retard it but doesnt seem like its doing anything
 

·
LUCKY SLIDES 2 2/25/06
Joined
·
504 Posts
Skoodles said:
no it doesnt do it under hard accelaration and i just put little more than a quarter of gas 93 octane in just waiting for the 86 to burn away..also i got to from an exxon station from wut i heard those are the best quality gas stations.. ill check the plugs tomarow but, i really think its something to do with the timming cause it did it befor, then i retarted it and it ran slow and ate gass bad. so then i advanced it again and it ran fine for a while. then now it started doing it again but louder and now i tried to retard it but doesnt seem like its doing anything
shell is the best bet for gas v-powah
 
1 - 5 of 5 Posts
Top