Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
Hey guys!
Haven't posted here in a while. Haven't really had any problem I guess.

Anyway...I have one now. I drove my car home from work last Thursday night w/o incident and went to Florida for a few days vacation.
Well yesterday I fired her up and to go to work and as soon as I started the car the BRAKE and BATTERY red warning lights came on and stayed on.
I was a little nervous, but drove her to work anyway. I know we had a little bad weather around here (NJ) while I was gone so I figured maybe some moisture pissed some connection off somewhere.

The round trip is about 70-80 miles. Figured that would dry things out. No such luck. Same problem this morning. :mad: Well my battery is like 3 years old so I took a chance and threw a new Autozone Duralast in. No help. Still have both lights. I even topped off the brake fluid even though it was only midway between MAX and MIN marks. Didn't really think that would help either. It didn't

Any suggestions? I figure alternator is a suspect, but I don't think that explains the BRAKE light at all.

I hate when cars break when not in use...so much harder to diagnose!!! And electrics is my weak spot to boot.
P.S. '94 Sentra LE w/ the 1.6L motor. Manual tranny.
 

·
Registered
Joined
·
111 Posts
None of my lights lit up when my alternator died. The battery warning light didn't turn on until after the alternator was replaced, when the belt snapped.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #4
yeah the FAQ I linked to above does mention that your scenario can also happen. I replaced my alt. w/ a rebuilt from AutoZone (Duralast brand)...so far so good. No lights!
 

·
Registered
Joined
·
44 Posts
I had the same issue with mine, changed out the alternator and both lights went out. Both the brake light and battery light do come on when the alternator goes bad.
 
1 - 6 of 6 Posts
Top