Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I recently purchased an 87 sentra from my uncle, 108k miles on it and in pretty good shape. There are only a few minor issues, I fixed most, except the light in the dash/instrunment panel...where the spedometer is and stuff...when the lights are on it is pitch black, any tips or suggestions on what it might be?
 

·
Registered
Joined
·
1 Posts
Dash light - same here

First, have you checked your fuses? I would guess that you have, but since you didn't mention it, I thought I would.

That being said, I have the same problem! (87 Pulsar) My headlight switch was out for a while, and I used jumper wires to turn the lights off & on. The dash lights went out at some point, but since I was basically guessing at the wiring, I didn't think anything of it. I bought a working but used switch, and now have no dash lights, and my fuses are all good. I suspect I either shorted & burned a connection somewhere, or all my bulbs failed (unlikely).

BTW, the light for the heater/AC controls is gone as well, although the light that illuminates the cigarette lighter is still good.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Yea, it was the fuse...I thought I checked them, but one was missing, the A.S.C.D one, whatever that stands for. So it all works now =)
 

·
Registered
Joined
·
8 Posts
I had this same thing in my pulsar this last winter, it keep blowing the fuse for the dash lights, markers, and taillights. After a lot of searching for the short and tearing the whole interior apart I found the light bulb that illuminates the hvac controls was bad, due in part by a loose connection. The bulb socket uses a push in style bulb and the terminals had relaxed after time. To fix it I just pried the terminals back together again and replaced the bulb. Problem solved. The light for the automatic trans shifter indicator was starting to do the same thing so I fixed it at the same time.
 
1 - 4 of 4 Posts
Top