Nissan Forum banner

1 - 8 of 8 Posts

·
Please Shift Here
Joined
·
6,696 Posts
Discussion Starter #1
ok I was driving back to orlando last night and I decided to use my cruise control on I-4. When I switched the cruise controlo on, the light would go on in the cluster but nothing would happen, the car would decellerate as if there were nothing puching the gas, then once it went down 10mph, the cruise control would floor it, then kick out and the light would turn off.

I can only assume this is what happened:
When I left my house, I decided to put the cruise control on (the switch by the light dimmer). As I was driving (with the computer active) I cought up to some Celica that wanted to race on the hi-way. So, of course, I accepted his challenge and during the race, I hit my speed limiter (109). Later on, when I hit I-4 I decided to hit the coast button on the steering wheel and then the cruise control started acting funny.

Do you think the cruise control's problem is due to the fast that I was traveling @ 109 for like 2 minutes straight :)D)? What else could it be? I stopped at a rest area and turned off the engine and it still acted funny afterwards.
 

·
Registered
Joined
·
1,064 Posts
That is probably your problem. It could be that when you were racing with the cruise control computer on something happened. Especially when you hit 109.
 

·
Administrator
Joined
·
1,075 Posts
Could be a problem with the vacuum hose to the cruise control unit. This happened with my B13 a while ago because the vacuum hose had been knocked loose.
 

·
Administrator
Joined
·
1,075 Posts
1997 GA16DE said:
where would I find the vacuum hose?
I've attached a picture of the unit in my B13. It's mounted on the firewall on the driver's side. From what I've seen the B14 is essentially the same. You can see the vacuum line on the right side of the picture, with a cable on the left that goes to the throttle. Check and see if everything is still hooked up correctly and that the vacuum line isn't cracked or something. I had the exact same symptoms as you when the vacuum line was accidentally knocked loose.
 

Attachments

·
Registered
Joined
·
179 Posts
Cable Tension

I have tried to tighten my throttle and cruise control cables several times and I have no luck. I would like to get back that firm gas pedal feeling but I am at the end of my cable. What do I do? It seems kind of pointless to replace the whole cable just to get a firm pedal.
 

·
NF's Offical Post Whore
Joined
·
1,972 Posts
I have the same problem with the cruise light on but not working, thanks for the tips:) i'll check it out tommorow
 
1 - 8 of 8 Posts
Top