Nissan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
1990 300zx n/a....so i just got an aftermarket head unit installed in my z today and well the stock speakers are garbage man.....but my car been acting weird....i think it's the alternator....everytime i lower my window, turn the a/c on and brake my headunit dies and then my car died and wouldn't start again....DAMN....i'm guessing its the alternator because i heard somewhere that if you start your car and take out the negative terminal your car should still run if it doesnt then its ur alternator so either i'm right or my car is just trippin :mad:
 

·
Power FC Z32
Joined
·
2,147 Posts
1990 300zx n/a....so i just got an aftermarket head unit installed in my z today and well the stock speakers are garbage man.....but my car been acting weird....i think it's the alternator....everytime i lower my window, turn the a/c on and brake my headunit dies and then my car died and wouldn't start again....DAMN....i'm guessing its the alternator because i heard somewhere that if you start your car and take out the negative terminal your car should still run if it doesnt then its ur alternator so either i'm right or my car is just trippin :mad:
Do you have a aftermarket volt gauge? When the car is runing and it's putting out 13.5V or less the alternater is bad or going bad. And the check to see if your battery is ok run the car for 3 minutes then shut it off. If the battery reads less then 12.1v then the batter need to be charged or replaced.

As for the other comment that Z32 are riddled with electrical problems that is false. The only times, I have encountered electrical problems is caused by owner or installer errors.
 

·
Power FC Z32
Joined
·
2,147 Posts
I know quite a few Z owners most of which bought stock and then modded. If you havent see any, it doesnt mean it doesnt happen. You never see your parents having sex, but you are proof that they do.
I'm the original owner of my 1992 TT and never had a problem with the electrical except for some fuses which are normal. I have worked on quite a few 300zx including Zhound's so yes, I do know what I'm talking about.
 

·
Registered
Joined
·
737 Posts
"As for the other comment that Z32 are riddled with electrical problems that is false. The only times, I have encountered electrical problems is caused by owner or installer errors."

I second that comment and none of my Zs or other Nissans had any issues except for the few I created. Oh and btw don't mess with the battery terminals while it's running, the Z32 is very dependent on a sound running electrical system (owner error). Was once true back in the day, but with all the modern advancements in automotive electrical systems there is way too much at risk.

... Remove the starter and have it tested instead, until then I don't think you need to turn the A/C on while opening your windows & braking while jamming out. As for the stereo and speakers, if you had the factory Bose (1-ohm) system ('90?) then you may have an Ohm matching issue running an after-market deck (normally 4-ohms). All in all though, it shouldn't disable it if installed correctly ("installer errors").

I'd start with the stereo install and security system if so equipped. Good Luck, Z
 

·
Registered
Joined
·
66 Posts
I'm the original owner of my 1992 TT and never had a problem with the electrical except for some fuses which are normal. I have worked on quite a few 300zx including Zhound's so yes, I do know what I'm talking about.
No one said you dont know what you're talking about....I said just because YOU dont see it, doesn't mean it doesn't happen. I've owned 2 Z32s and own a fully built TT Z33 now....I am not a noob with the Z.
 

·
Registered
Joined
·
66 Posts
How would a third party interpret your quote?

Also I never said you were a noob. I only corrected your statement.

Sincerely,

Sponge...
I understand...just mentioning what I went through and see alot of the other Z buddies go through....

friend of mine bought a used stock Z32TT about 9 years ago. Ran good, but didn't have the acceleration is should have. No check engine light and no other symptoms except the lack of power. Dealer tested everything and several sensors were bad which was hindering performance. Changed them out and 3 weeks later he was having electrical issues...lights dimming, car dying....grounding issue. Same things many of the Z32 guys experience in my area....if you know about them, they are easy fixes, but tracking down all the crap that I have seen go wrong in the Z32...great car as I love the Z...I just experienced more issues than the average person I guess.
 

·
Power FC Z32
Joined
·
2,147 Posts
The thing is you are not using the original owner as your example. Who knows what the original or previous owner has done to your friends Z in the past.

Also it does seem you have more electrical problems the the average owner. Do you have FSM (Factory Service Manual)? If your ok with electrical it has a detail schematic and I have used it when installing car stuff?

Here is a free onliner if you do not have one.

http://www.nissanforums.com/z32-chassis-300zx/110965-online-z32-manual.html
 
1 - 11 of 11 Posts
Top