Nissan Forum banner

1 - 3 of 3 Posts
K

·
Guest
Joined
·
0 Posts
Discussion Starter #1 (Edited)
Well finally got new sturts and spings on the sentra, decided to take it out and wash on thrusday morning. I went out got in the car and it started fine, drove to the car wash. Washed the car got it to leave and it again started fine, left went by a friends shop to BS, decided to leave went and hopped in the car *no start*. No turning over, nothing. Figured it was a bad battery or starter, one so we push started the car and took it home.

I pulled the started out took it to the parts store to have it tested, it turned over but made some nasty sounds so I decided to go ahead and replace it. I had the hitachi unit, but the parts store gave me the mitsu unit they said it would work the same. So I went home installed the new starter jumped in the car and no start still :( :( .. At this point I am thinking the battery may be the problem even though the lights, radio, etc looked fine. So I ran to my brothers shop and picked up a new optima battery throw it in the car and still nothing. I cleaned the ground contact for the battery and all the terminals seem tight.

I can hear the fuel pump running and relays click under the hood, but no start! I tried hot wiring the fuel pump and the heard the solenoid click but it still will not turn over! So I called the parts store had them order me a new hitachi unit, I am going to try it in the morning but I doubt it will fixe my problem..

You guys have any ideas???


A little background on my car, it's a 92 SE-R with a bluebird DET swap and a battery re-locate kit. The car has been running for about 8months since the swap with no problems.

Please let me know if you all have ANY input.


Thanks
James
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Fixed it guys, I even used the mitsu starter and love it!

All my problems where due to a faluty ground, I put a nice big 2gauge ground start on one of the starter bolts and it works like a champ.
 
1 - 3 of 3 Posts
Top