Nissan Forum banner
1 - 8 of 8 Posts

·
i smell that whore
Joined
·
230 Posts
Discussion Starter · #1 ·
i just installed a topspeed header, and the hooks won't go onto the hangers. it feels like the secondary is pretty stable, but i have heard it dragging over some speed bumps and such. i'm pretty sure i put the "u" shaped thing on correct, with the side that's marked "R" on the passenger side. also, i have a slight buzzing (sounds kinda ricey) between ~3300 and 3800 rpm. what could be causing this? it only happens when i am pushing the car hard, but if i gradually give it gas, it doesn't seem so bad. also, when i just rev the car without load, it doesn't happen. suggestions? thanks - jeff
 

·
Think outside "The Box"
Joined
·
250 Posts
It could just be that "tuning" effect of the sound resonating through the headers into the exhaust. Usually it happens at peak torque of the motor, when it crossed the hp line increasing.
 

·
Not Anymore.
Joined
·
5,014 Posts
did you get a new exhaust manifold gasket or did you use your current one?
 

·
Registered
Joined
·
2,022 Posts
i hot some HotShot headers for my 92 s13....havent install them yet....waiting of the cold air extension.....you guys think it would sound agressive? i got a Apexi N1 straight 2.5 inches piping full
 

·
i smell that whore
Joined
·
230 Posts
Discussion Starter · #6 ·
NickZac said:
did you get a new exhaust manifold gasket or did you use your current one?
i used a new gasket.
 

·
Powered By hopes & dreams
Joined
·
8,328 Posts
you bought a cheap header. the fit isn't going to be perfect. where'd you get it? e-bay?
 

·
i smell that whore
Joined
·
230 Posts
Discussion Starter · #8 ·
chimmike said:
you bought a cheap header. the fit isn't going to be perfect. where'd you get it? e-bay?
i bought it from a member on sr20forum. he got it from jgy, who sells them for $270. it was brand new, i got it for $150 shipped. it's not a fitment issue, it sound like it a buzz coming from around the cat, but i'm pretty sure it's not the heat shield, cause i tightened up all the bolts. the thing that i worry about is the hangers. i couldn't get the front hooks on the front of the cat back on the rubber hangers. could this be the problem? oh yeah, it's not rubbing on the oil pan, the oe manifold bracket, or the bottom of the car.
 
1 - 8 of 8 Posts
Top