Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
So I posted before about how high my ****ing clutch was when I bought my car and how I though I glazed it. Well now it's definitely slipping when I jump on the accelerator, and lets just say I can't even get the tires to chirp in 1st gear. So is it definitely the clutch or something else? I adjusted the clutch and it feels just about perfect, but still slips like it was before. Can I just replace the clutch and refill the fluid and be good. I;m doing it with some help from my dad and his tools, but don't want to get lost in it all and end up having to do a bunch of other shit, because my Z is my only transportation. I found many guides on it online, not too hard, I replaced my auto tranny from a 93 cavalier z24 and it wasn't a piece of cake, but it worked with no problems. I just hear stories about these cars being a ****.
Thanks for reading and any help you can give me would be greatly appreciated! BTW I'm thinking of getting an ebay clutch, broke, thus why I'm doing it myself. Does any one have any recomendations? I'm not planning on spending more than $150 on a clutch kit
 

·
Power FC Z32
Joined
·
2,147 Posts
How many miles did you break in the clutch? If the glaze is minimal your clutch will go back to normal under light driving.

Please do not curse when posting? Children do look at this forum.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Heh I was drinkin last night. I didn't put a new clutch in, I'm not sure when the last time it was, the guy I bought it from got it in 03 and I know he didn't replace it, so is it time? I'm just hoping it's not one of the cylinder twins.
 
1 - 3 of 3 Posts
Top