Nissan Forum banner
1 - 4 of 4 Posts

· B13 Owner since 90
Joined
·
139 Posts
Discussion Starter · #1 ·
This is with KYB AGX's w/ Ground Controls 300/200, Koni Polyfoam Bumpstops and Shigspeed Pillowball mounts
the GC's and AGX's where assembled using the duct tape and silicone method and where left to harden 3 days before install


the right rear is where the noise is coming from on my B13 SE-R

i have had this noise and have tried finding sources i.e checking swaybars are tight, the exhaust is not hitting the sway bar, the collar of the GC is siliconed/duct tape'd shut and so it will not budge, i pulled the entire strut assembly and checked everything over and made sure everything is assembled right.

is there a possibilty that when i used a short burst of the compressor gun to tighten the top nut that holds the PillowBall mount in place that it might have unscrewed something inside the strut?

Help

Scott, anyone?

Tevs
 

· B13 Owner since 90
Joined
·
139 Posts
Discussion Starter · #3 ·
Scott,

i was using the stock mounts for about a month before upgrading to the PillowBall mounts, and i used the bushing between the hat and the mount .

i will take everything apart and closely inspect everything, specially the top hat.

thanks Scott.

Tevs
 

· B13 Owner since 90
Joined
·
139 Posts
Discussion Starter · #5 ·
are both front and rear strut shafts 18mm?
and if not then front is 20 and rear is 18,
and GC used a 20mm top hat on all four corners?

Tevs
 

· B13 Owner since 90
Joined
·
139 Posts
Discussion Starter · #7 ·
i purchased a new old kit which used to be Jon Hall's, it did not have the Ground Control logo marking on the collar like the new one's now, the top hat does have a lot of slack around the strut shaft, so i will have to order the updated 18mm top hats for the rear.

thx again Scott,


Tevs
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top