Nissan Forum banner

1 - 7 of 7 Posts

·
B13 Owner since 90
Joined
·
134 Posts
Discussion Starter #1
This is with KYB AGX's w/ Ground Controls 300/200, Koni Polyfoam Bumpstops and Shigspeed Pillowball mounts
the GC's and AGX's where assembled using the duct tape and silicone method and where left to harden 3 days before install


the right rear is where the noise is coming from on my B13 SE-R

i have had this noise and have tried finding sources i.e checking swaybars are tight, the exhaust is not hitting the sway bar, the collar of the GC is siliconed/duct tape'd shut and so it will not budge, i pulled the entire strut assembly and checked everything over and made sure everything is assembled right.

is there a possibilty that when i used a short burst of the compressor gun to tighten the top nut that holds the PillowBall mount in place that it might have unscrewed something inside the strut?

Help

Scott, anyone?

Tevs
 

·
Registered
Joined
·
31 Posts
Sunny said:
This is with KYB AGX's w/ Ground Controls 300/200, Koni Polyfoam Bumpstops and Shigspeed Pillowball mounts
the GC's and AGX's where assembled using the duct tape and silicone method and where left to harden 3 days before install

is there a possibilty that when i used a short burst of the compressor gun to tighten the top nut that holds the PillowBall mount in place that it might have unscrewed something inside the strut?

Help

Scott, anyone?

Tevs
How long did you have the GCs installed before upgrading to the mounts? After a while of driving on stock mounts, the strut shafts can wear the inside diameter of the top hat leaving it out of round. It may be that even though you have the mounts, the hats are damaged, allowing them to rattle.

If something inside the strut is unscrewed, you may be (un)screwed! Hopefully it's just the top hat. They're pretty cheap. You have the urethane bushing between the hat and the mount, right?

Good luck,

-Scott
 

·
B13 Owner since 90
Joined
·
134 Posts
Discussion Starter #3
Scott,

i was using the stock mounts for about a month before upgrading to the PillowBall mounts, and i used the bushing between the hat and the mount .

i will take everything apart and closely inspect everything, specially the top hat.

thanks Scott.

Tevs
 

·
Registered
Joined
·
31 Posts
Sunny said:
Scott,

i was using the stock mounts for about a month before upgrading to the PillowBall mounts, and i used the bushing between the hat and the mount .

i will take everything apart and closely inspect everything, specially the top hat.

thanks Scott.

Tevs
I know in the past GC has used a top hat with a 20mm. hole in it. Too bad our rear strut shafts (on stock and most aftermarket struts) are 18 mm. Check to see that the hole is the right size too, cuz if you're using the 20 mm. hole one, it'll rattle as well.

Later!

-Scott
 

·
B13 Owner since 90
Joined
·
134 Posts
Discussion Starter #5
are both front and rear strut shafts 18mm?
and if not then front is 20 and rear is 18,
and GC used a 20mm top hat on all four corners?

Tevs
 

·
Registered
Joined
·
31 Posts
Sunny said:
are both front and rear strut shafts 18mm?
and if not then front is 20 and rear is 18,
and GC used a 20mm top hat on all four corners?

Tevs
Stock the fronts and rears are 18 mm. Aftermarket (AGX, GAB for sure) is 20 mm. front, 18 mm. rear.

The early versions of the kit ran 20 mm. hats all around. Make sure your kit has the right size hole.

For reference, the Koni's that I use have 22 mm. shafts all around...

-Scott
 

·
B13 Owner since 90
Joined
·
134 Posts
Discussion Starter #7
i purchased a new old kit which used to be Jon Hall's, it did not have the Ground Control logo marking on the collar like the new one's now, the top hat does have a lot of slack around the strut shaft, so i will have to order the updated 18mm top hats for the rear.

thx again Scott,


Tevs
 
1 - 7 of 7 Posts
Top