Nissan Forum banner
1 - 15 of 15 Posts
G

·
Discussion Starter · #1 ·
alright so I rigged up a puke-looking GHETTO airbox, which actually makes my engine sound nice, but now my check engine light is on! I tried disconnecting the battery, waiting a while, reconnecting it, running my car for 15-20 minutes, then driving it for a few minutes. the light is still on.

Do you think it's still the ghetto airbox that's messing with the ECU, or do I really have an engine problem?
 

·
tiffany was hardcore?
Joined
·
195 Posts
when you removed the air box did you remember to plug everything back in! there is a little sensor that is attached to the air box at least in a 99 there was check it out :eek:
 
G

·
Discussion Starter · #4 ·
Same thing happened to me... Unplug the battery and leave it off for about 30min. to an hour. If that doesn't turn it off. Just make sure all items are plugged back in and a in a few days it will go out.
 

·
West Coast *******
Joined
·
1,127 Posts
James said:
talk to your car... hahahahahahahaha....
In other words "Read" The engine code from the ECU, so you know what's up with your car. I personally have never done it, but my dealer will run it on their OBII scanner for no charge (I've spent more close to 2k on car repairs this year alone). Its so simple. All they do is plug it into the reader, go through some screens, and get you a printout. I know on sentra.net there is a whole page on ecu codes.

-Sam
 

·
West Coast *******
Joined
·
1,127 Posts
James said:
it's a simple process but i'm getting tired of explaining it to ppl... i should keep my response on file... that way i'd just copy and paste...
Good Idea...if they want instructions, they have to paypal you a buck :)
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top