Nissan Forum banner

1 - 18 of 18 Posts

·
Tuner/Mechanic
Joined
·
266 Posts
Discussion Starter #1 (Edited)
if anyone can help me, i would be GREATLY appreciative. anyway, today my car started dying. if i push in the clutch, it dies. i can keep it running by pumping the gas or popping the clutch. at about 2k rpm, it will run fine as long as i am not pushing on the gas much. i think it might be the fuel pump. i passed 100k yesterday, and maybe its that time? i don't know what the hell is going on. anyone who can help PLEASE! or if you live in lex ky, and you could possibly take a look at it, you would be the sh!t. TIA! ~mike
 

·
Still moderating..sorta
Joined
·
1,324 Posts
Check all your vacuum hoses. When I had one crack, the engine would barely idle but above 2000 RPMs it ran fine. We have different engines but it is worth checking out and you can easily do it yourself.
 

·
Tuner/Mechanic
Joined
·
266 Posts
Discussion Starter #8
thanks, but the engine won't go above 2k rpm even if i floor it! black sh!t comes out the muffler, oh yeah, and it started smoking real bad earlier! this sucks, but i think its time for the sentra to go:(
 

·
Still moderating..sorta
Joined
·
1,324 Posts
Just go to any mechanic. Doesn't have to be a Nissan dealer.
 

·
Tuner/Mechanic
Joined
·
266 Posts
Discussion Starter #10
the only mechanic here that i trust is about 150 to do a thorough breakdown. besides, i finally pinpointed my oil leaks...plural...rear main, backside of the head, AND the oil pump housing leaks somewhere. anyway, its time to get a new engine or get a new car. we'll see what the mechanics say. if you think you know what it is, i'm all ears.....TIA
 

·
Registered
Joined
·
85 Posts
I had the same problem with a Tempo, I replace the pump and fuel filter, replaced the valve cover gasket, payed to have the injectors directly cleaned, change a couple othe small part all did nothing, so in the end after I traded it in for my Nissan Sentra, I came to realize if anything my car wasnt getting the compresion it needed.
 

·
Registered
Joined
·
8 Posts
try this

If ur blowing smoke out ur exhaust then it maybe the rings that are leaking oil and then the color of your smoke should be bluish, anyway if thats what it is and the smoke is black then ur cylinders might have to much shit in them and the burn isnt proper. U hould start be checking ur oil, then check all ur cables, wirs hoses and shit. And a 100k isnt alot for a nissan I have 3 with high miles, 125k, 117k, 90k, all run as good as the day I got them
 

·
Registered
Joined
·
149 Posts
The bluish smoke is a great indicator. Happened to a good friend of mine that was having troubles as well. After some advice, he turned it over while I watched the exhaust and sure enough ... it was blue. Took it the local mechanic and now all is well.
 

·
Tuner/Mechanic
Joined
·
266 Posts
Discussion Starter #17
thanks for all the input guys, i know i need to do a combustion chamber cleaning really bad, but i found the problem last night. a loose wire connecting the throttle body to the computer. the wire had just come off. it took way to long to find, but it runs like it should again! thanks again. BTW, i fixed a few other little problems from the suggestions posted here. THANKS! ~Mike
 
1 - 18 of 18 Posts
Top