Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I just bought a used '91 Nissan Stanza. everything under the hood is almost brand new, however I'm having a problem with the car, everytime I stop at a light the car starts to shutter. The shuttering doesn't start until the engine gets warm. What is causing this to happen in the car? There have been several things replaced just recently, such as the the fuel injectors, water pump, raditator, and several hoses, and battery. If anyone can help me I would greatly appreciate it. B.
 

·
Registered
Joined
·
9 Posts
Bethanny1381 said:
I just bought a used '91 Nissan Stanza. everything under the hood is almost brand new, however I'm having a problem with the car, everytime I stop at a light the car starts to shutter. The shuttering doesn't start until the engine gets warm. What is causing this to happen in the car? There have been several things replaced just recently, such as the the fuel injectors, water pump, raditator, and several hoses, and battery. If anyone can help me I would greatly appreciate it. B.
Sounds like it could be the motor mounts. I'm having the same trouble with my '91 Stanza. It shakes in idle and shakes especially hard when the AC is on. Check the front right mount for cracked rubber. There are three engine mounts. Two in the front and one in the back. The front right one is the most likely to go but I would replace all three if you can. Let me know if you want recommendations on places to buy these.

Andrew
 

·
Biru O' Kudasai
Joined
·
1,426 Posts
Put brand new NGK standard copper spark plugs in because if it has any other plugs in there I have found idle issues can be caused by the more expensive or exotic plugs. Also check the ignition timing and the throttle position sensor settings?

Troy
 
1 - 4 of 4 Posts
Top