Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Heres the deal...I have a 93 SE-R...110k New plugs, wires, cap, rotor...
When i let my car warm up for about 30min then go to drive it likes to almost stall or sometimes stall. I will put it in reverse drive backwards and then when i put the clutch in and take my foot off the gas the RPMs go almost all the way down, and sometimes it stalls. It does the same thing when i come up to stop signs/light. Then when i get out of the car the exhaust smells like ass. It really olny does it when i let it warm up(once and a great while when i dont) but when i dont let it warm up its fine..and it idles at 1500RPM's...the car runs great other than that. I am going to replace my O2 sensor and my coolant temp sensor, and i have a fuel filter for it as well. DO you all think that will fix it or is there somthing else i need to do. Thanks
-Ben
 

·
Registered
Joined
·
1,818 Posts
A smelly exhaust is usually a sign of a failing catalytic converter. If yours is creating a lot of back-pressure, it would cause those symptoms.

Lew
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
But see it doesnt smell all the time..i know its running rich...i am almost sure of it. You think the O2 sensor has anyhting to do with it? I dont have any CEL's but it could still not be working right and not throws any CELs. And i am getting horrible MPG as well.
-Ben
 

·
Registered
Joined
·
114 Posts
Smelly exhaust is usually a sign of sulfur buildup in the catalytic converter, it's producing Sulfur Dioxide, which is whats in stink-bombs. Does it smell like rotten eggs?

There is at least one additive product I know of that claims to clean this out, but you're probably better of with a new catalytic converter. A failing O2 sensor may be the root cause of this, but it sounds like it has also hosed the converter.
 
1 - 4 of 4 Posts
Top