Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
Hello everyone,

I have been trying to battle an issue with my car for a couple years now and don't know what's going on. I have a Nissan 200SX SE-R with a W11 Avenir SR20DET swap. Running a JWT ECU.

My issue is when I give a little gas around sharp corners and have 1/4 tank of gas in the tank, the engine just cuts/sputters/jerks out momentarily. It literally feels like I hit a wall for a second. Eventually the engine resumes, but there is quite a significant RPM drop when this happens. I just replaced the fuel pump (thinking that could be it) with a 350LPH one and have brand new plugs and fuel filter. Also have brand new plugs. It seems like maybe fuel is sloshing around to one side of the tank and isn't getting through to the fuel pump. How do you even fix a problem like this?

Anyone have ideas what this could be?

Regards,

Mike
 

·
Sup Mod keeping the peace
Joined
·
6,213 Posts
If it's OK with a 1/2 to full tank, maybe the fuel pump pickup screen isn't far enough down into the tank where it should be; due to being the wrong pump model or an aftermarket tank that's an incorrect replacement for the car. In the meantime keep more gas in the tank and slowdown when making turns.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
@rogoman Thanks for your quick reply.

I was able to solve the problem. First of all, I used the old sock when I replaced the fuel pump. Went to O'Reillys and picked up a new sock for the pump. Also, my fuel return line was just dangling in my fuel tank. I noticed a nipple on the enclosure for my fuel pump that had nothing connected to it, so I attached the return line to that.

I do have to say, my car runs amazing now!
 
1 - 3 of 3 Posts
Top