Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
A few days ago I was installing at alarm on my car, the ignition red with white cable shorted with ground and now my car don't start. Could my ecu be fried I check all my fuses, the distributor coil sparks but the cap does not make a spark.
 

·
NF Mod/Nissan Master Tech
Joined
·
9,440 Posts
If the coil sparks, but you are not getting spark out of the cap, I would be checking for a bad distributor cap or rotor. Sometimes the bolt that holds the rotor to the shaft falls out.
 

·
NF Mod/Nissan Master Tech
Joined
·
9,440 Posts
I don't either, but the fact that you are getting spark out of your coil but not out of the cap suggests there is an problem with the cap and rotor. The spark is being triggered, which means the ECM is getting the signal from the distributor's position sensor and telling the coil to fire. If the coil is generating a constant spark to the distributor cap and there is no spark coming out of the cap to the plug wires, there is obviously an issue between the coil wire and the plug wires (meaning cap and rotor issue). Might be just coincidence and it doesn't mean you don't have other issues that may or may not include the ECM, but you have to begin with the basics, first. Spark and fuel are #1 and #2 on the basics!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
i check the plugs there sparking, this are the things i change and still no good
ignition switch
ecu
starter
fuses
relays
when i took off the spark plug there only are mixing no fuel..
 
1 - 6 of 6 Posts
Top