Nissan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
My SR20DET works like a dream... We swapped the old ka24de with auto for a red top SR20DET and it runs great the 31/2 inch ss exhaust roars but the tachometer refuses to work. I was told that the 91 or newer instrument cluster would solve this but it hasn't. I have done huge amounts of work on this car and loved it all but the tach really has me perplexed.
Any advice would be greatly appreciated.
 

·
Registered
Joined
·
1,171 Posts
your gonna have to use the jdm guage cluster thats the only way i got mine to work.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
Thanks Chris
I am trying to keep the dash as stock as possible. Cops are less likely to give me too many problems if they don't know what is under the hood. :cheers:
 

·
Registered
Joined
·
189 Posts
hehe Thats what Im doing. Only reason Im going to an aftermarket tach is for drag because I want a shift light so I dont have to look down when to shift. Also the guage im looking at has a boost and oil pressure guage built in so it will save me some money if they all work properly.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7
The key is getting it to work. Let me know how it goes. I just ordered a cluster off of ebay for $50 US. hopefully third time is a charm... I will be selling the other two as soon as this one arrives. What type of boost meter are you going with? Good luck on the strip.
 

·
Registered
Joined
·
189 Posts
Well if the one on the tach I might get doesnt read right I got an autometer one. Well I dont own it yet but my friend will seel me his. I just bought my 3 inch down pipe and new slim battery for my front mount intercooler upgrade. :thumbup:
 

·
Registered
Joined
·
33 Posts
Discussion Starter #9
good for you. I went with the trunk mounted battery(easier for the amp hook up.) the hard part with the intercooler was moving the window washer fluid res... a couple of new brackets and a 3 1/2" hole cutter and it really wasn't that bad though. The battery tray is a B to cut through so have lots of cutting oil handy. Good luck. If you want pics I can email you what I did... I am new to the forum and am not sure how to post them...
 

·
Registered
Joined
·
33 Posts
Discussion Starter #10
Still can't get tachometer to work

Well the Jdm cluster showed up and still no joy.... The Ecu doesn't seem to be sending a signal. Does anyone know if there are any signals to the ecu that may be required for the tach signal to work? (that may have been cut)
still banging my head
 
1 - 10 of 10 Posts
Top