Nissan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Been trying to get the AC figured out in the car 03 Altima 2.5 she bought. It’s not blowing cold, but the fans work just fine. Started out by checking all the fuses, and they look good, even switched the relay out and I still couldn’t get the compressor to engage. The clutch will move when I turn it by hand, but it has power going to it, I checked that with a test light. I even tried jumping it too to see if it didn’t have enough power going to it and still had no response from the ac clutch.

At this point I think it would have to be the ac clutch that’s failed, because it seems that it should be forced into operation when I put power to it, and I’m pretty sure it’s getting power anyway. I’ve read that the PCM can prevent it from engaging if the Freon levels are too low, but I don’t see any other way that the compressor is wired into the electrical system for it to even communicate with the computer. Besides that, there’s about 40 psi on the low side pressure anyway so it should override and kind of cutoff or so I think.

I’m going to buy a used compressor assembly tomorrow and install it, I just wanted to ask everyone if there could be any other possibilities based off what I’ve seen, or have I narrowed it down to the compressor/compressor clutch?
 

·
Sup Mod keeping the peace
Joined
·
6,157 Posts
If you apply 12 v from the battery directly to the compressor clutch wire with a jumper lead, it should activate the compressor. If that doesn't happen, the clutch is bad.
 
1 - 2 of 2 Posts
Top