Nissan Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
24 Posts
Discussion Starter · #1 · (Edited)
OK folks, my background in mechanics is old chevys and jeeps. I bought the Sentra for a commuter. So far I'm digging the 32 MPG over my Jeep's 16 MPG, it's like, well, double.

My first issue is the SES light and cam position "actuator". I put it on my scanner and came up with P0011 ("Cam position actuator, bank 1, timing over advanced"). After some searching I came up with varying pics and diagrams. Apparently placement of the sensor has changed over the years.

The replacement of the cam position sensor looks pretty straightforward. 1 bolt and bing. It also looks like there's only 1 way for it to go in. Is there an adjustment. Autozone's website says that 2 are required. Is one BANK 1 and the other BANK 2? or are those error code storage areas. I've cleared the code twice with my OBD II scanner and it returns.


Could it be that the wiring is just funky or should I replace the sensors. I'd like to exhaust all my options before taking it to a shop, but with my limited experience with Nissan's I don't want to screw anything up.


Thanks

P.S. 2002 Sentra GXE (is that a b15) AND do I have a timing belt or a CHAIN?
 

· Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
OK,
I'll try this once more. Has anyone had this code?? What did you or your mechanic do about it?? Do I need to check my connectors?? Wiring?? Does this mean the sensor(s) is toast??

:confused:

C'mon folks, I know I'm not the only one with this problem.

If I had a squeaky fan belt would I get more (any) responses??? If I wanted to put fog lights on the roof or paint my wheels purple maybe someone would chime in.

Anybody???
 

· Registered
Joined
·
4 Posts
just checked this post. i had posted mine with same issue but had no response. dumbo u didn't see my post ? u couldn't respond to mind when we talk about the same issue..but u expect someone to answer you.. !

1 thing in common.. this forum suck coz neither did i have any response for months.

i had same problem. p0011. 2002 nissan sentra gxe.
took to dealer. he said will cost $600 to fix it.
i have not done anything.just analyzing things out.
 

· Registered
Joined
·
14 Posts
well ive been takin classes for almost 4 years now in automotive and my advice to u is if the obdII sensor says its the camshaft sensor then i would just change the one it says unless its a cheap autozone sensor thats telling you this in that case i would take it to nissan and ask for a diagnosis
 

· Registered
Joined
·
4 Posts
I took it to Nissan and its Nissan who said we have to change this.
spare parts costs 175..and labor is 330..total to 600+
they say that labor is flat rate. whether it takes 1hr work or 3days work. they will do it for $330.. which is a flat rate.

firestone said will do the same for around 300.. but they dont stand gurantee onwhether the prob will befixed coz they didnt diagnize...and they will just do what i ask them to do.. thats it.

pls suggest what should i b doing
 

· Registered
Joined
·
14 Posts
well first i dont know what diagnosing you have done what i would do would be to print out a wiring diagram of the camsensor and check for a broken wire or a bad ground or a if there is wire showing out of the insulator maybe its dirty or it might be shorted maybe dont think it'll be shorted thou because that'll blow some circuit breaker but if nothing there then the only thing you can do is change the sensor
 

· Registered
Joined
·
4 Posts
I couldn't understand much. the engine lights popped up and i took it to Nissan for diagnosis and they told me need to replace some intake value. if not fixed said more gas will be used and will affect my mileage. parts cost $170 and labor is fixed charge no matter what is the job. its $330.... firestone said will do the job for around $300
 

· Registered
Joined
·
14 Posts
so is it the camsensor or the valve or both but yeah i think you dont have much choice changing that valve that could cause the light to go up because since the valve is probably bent or worn out of spec that it might of jumped timing to maybe thats why your sensors not right maybe its easier to explain talking verbally not then it is typing but if its that then i dont think you got no other choice
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top