Nissan Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
About a month ago, after stepping out of a store, I noticed my brake lights were on, with the car off. I know nothing about cars, and the guy at auto zone said it was probably the brake light switch, so I tried to replace that, but the ones they showed as being compatible with my car, weren't. the plug was alot bigger on the switch, so he rigged up some wire connectors to the switch, and had me try splicing the wires. Did that, and the lights were still on with the new switch, so I got my money back & reinstalled the old switch.

I have checked and rechecked all the bulbs, I read that the brake lights are dual fillament, and those checked out ok. I noticed one night, the yellow lights on the front sides of the car, are also on very faintly.

Even with disconnecting my battery wherever I go, to save battery life, it lasts me about a week, before I have to do a full charge on it. Any help will be appreciated. I hate taking my car to the mechanic, because I always think it'll be another 500$ job like they usually are.. like when my fuel pump went out last year, in the middle of west texas desertland.

Thank you,
Vandermast.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
it's possible, but I have no clue on where to even start looking. from the brake switch, it goes into the "tube" of cables, and from there, I'm lost. I tried moving the tube o' cables around that was in the trunk, and still no luck, so it may not be in the trunk area where the short's at.
 

·
Registered
Joined
·
264 Posts
Are you sure its the BRAKES that are on and not just the TAILS? You said your side markers were on too and thats why I asked. The stalk on the side of the steering wheel that has the light switch on it may have a short. Just a suggestion.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
yes, it's the brake lights. when I turn the lights on and I look inside the trunk, at the bulbs, the other filament turns on, with the lights off, the "tail light" filament turns off too.
 

·
Registered
Joined
·
264 Posts
vandermast said:
yes, it's the brake lights. when I turn the lights on and I look inside the trunk, at the bulbs, the other filament turns on, with the lights off, the "tail light" filament turns off too.
Hmm... sucks bro. I know what your going through. I'm currently re-wiring a tanker trailer because the far left tail light is really bright and it back feeds the power through the system and causes all the lights on the semi to turn on. I unhooked all the wires to that tail light at the hub and it went back to normal. The wire is grounding on something but it doesn't make sense, its running through a plastic conduit, there is nothing for it to touch or rub against. It sucks and I feel your pain.
 

·
Registered
Joined
·
3 Posts
vandermast said:
About a month ago, after stepping out of a store, I noticed my brake lights were on, with the car off. I know nothing about cars, and the guy at auto zone said it was probably the brake light switch, so I tried to replace that, but the ones they showed as being compatible with my car, weren't. the plug was alot bigger on the switch, so he rigged up some wire connectors to the switch, and had me try splicing the wires. Did that, and the lights were still on with the new switch, so I got my money back & reinstalled the old switch.

I have checked and rechecked all the bulbs, I read that the brake lights are dual fillament, and those checked out ok. I noticed one night, the yellow lights on the front sides of the car, are also on very faintly.

Even with disconnecting my battery wherever I go, to save battery life, it lasts me about a week, before I have to do a full charge on it. Any help will be appreciated. I hate taking my car to the mechanic, because I always think it'll be another 500$ job like they usually are.. like when my fuel pump went out last year, in the middle of west texas desertland.

Thank you,
Vandermast.
The same thing is happening to my 95 Altima. The first thing is there are two different brake light switches for the 95 Altima. Bring your old one to the dealer and they will be able to replace it. But with that said ... I replaced my switch last night and the brake lights are still on. Right now I'm keeping the fuse out and driving with no brake lights until I can figure out what is wrong. :(
 

·
Biru O' Kudasai
Joined
·
1,426 Posts
I don't remember exactly but I think that there is a plastic button that the brake light switch contacts when the pedal is up. Check the contact pad on your switch(s) the threaded end of the switch and the pedal stopper should be between .012 and .039 in. if not then the stopper is broken or the switch needs to be adjusted.

Troy
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
That had fallen apart, but the guy at autozone said I could tape a penny to the spot where it was, and I did, and the switch does get depressed all the way with the penny there, I had to adjust the switch over a tiny bit, but it's making full contact. I remembered today, when I took the switch off, to put the (wrong) new one on from auto zone, and the cables were disconnected, the lights were still on.. and I had tried shorting the contacts with a piece of wire, and no change. does this mean the short is beyond the switch? somewhere between the path of the switch and the lamps? pulling the fuses causes no change either.
 

·
Registered
Joined
·
3 Posts
vandermast said:
That had fallen apart, but the guy at autozone said I could tape a penny to the spot where it was, and I did, and the switch does get depressed all the way with the penny there, I had to adjust the switch over a tiny bit, but it's making full contact. I remembered today, when I took the switch off, to put the (wrong) new one on from auto zone, and the cables were disconnected, the lights were still on.. and I had tried shorting the contacts with a piece of wire, and no change. does this mean the short is beyond the switch? somewhere between the path of the switch and the lamps? pulling the fuses causes no change either.
Did you pull the 3rd fuse down on the left side of the drivers side fuse box that is inside the car? That fuse should turn the lights off.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #13 ·
I have an updated symptom.. Cruise control, when turned on, will not activate, but after 30 seconds the cruise light blinks on & off until you press any of the cruise activation or deactivation buttons, then blinks again after 30 seconds.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #14 ·
ok I figured it out, after researching the cruise control symptom. I found there are 2 switches down activated by the brake pedal, side by side, one (the brake one) was severely hidden by the steering column when looked at from underneath. apparently I tried switching out the cruise control switch and not the brake switch. so I taped some more pennies to that side of the brake pedal, and sure enough, the brake lights turned off. I did find, though, my alternator's not working, hence the weekly necessity for charging.

Thanks for all the effort put into this, everyone. Hope those with the same problem find the same solution.
 

·
Registered
Joined
·
1 Posts
I just had the same issue pop up on my 240sx yesterday. I replaced the Brake light switch and the lights still wouldn't go off. I manually pushed the switch in and the lights went off! I then saw bits of broken plastic on the floor mat. It turns out the "button" that was on the brake pedal that was supposed to depress the switch had broken off. I went to the parts store and refunded the new switch and got a "rubber bumper assortment" for $8 and matched up the closest one to the "button" and tah-dah the old switch worked like a charm. And I didn't have to tape any pennies. When the "button" broke, it left a hole in the pedal that the switch was falling into.
 

·
Registered
Joined
·
1 Posts
I experienced the very same problem, got confused at first and tried to fix the brake lights staying on all the time, and then realized I had discovered how to fix my non functioning cruise control! I will try and include a picture
[/URL][/IMG]


My original problem still persists, in that my brake lights stay on ALL THE TIME. I did find and remove the fuse, (third one down on the left column of the fuse box panel)
but.....I cannot for the life of me solve the problem in the same way because I cannot find the brake light switch. The space in there is so tiny I think I need to use a shrinking machine to actually work in there lol. Can anyone clue me in as to WHERE the brake light switch is?
 

·
Registered
Joined
·
16 Posts
i am now having the same issue, try replacing the cruise control cancel switch... thats the one that the brake pedal contacts... i plan on doing mine when i get paid, i pull my fuse and my lights go off but i am also getting tired of pulling a fuse every time i turn my car off
 

·
Registered
Joined
·
16 Posts
I HAVE FIXED FIXED MY ISSUE, I REPLACED BOTH THE BRAKE LIGHT SWITCH AND CRUISE CONTROL CANCEL SWITCH AS WELL AS THE BRAKE SWITCH BUTTON THAT ALLOWS FOR THE SWITCH TO CLOSE, IT IS VERY TIGHT BUT IF YOU CAN MANAGE IT, I TOOK OFF THE STEERING COLUMN COVER TO ACCESS THE SWITCHES BETTER AND INSTALL THE GROMMET BUTTON
 

·
Registered
Joined
·
1 Posts
I HAVE FIXED FIXED MY ISSUE, I REPLACED BOTH THE BRAKE LIGHT SWITCH AND CRUISE CONTROL CANCEL SWITCH AS WELL AS THE BRAKE SWITCH BUTTON THAT ALLOWS FOR THE SWITCH TO CLOSE, IT IS VERY TIGHT BUT IF YOU CAN MANAGE IT, I TOOK OFF THE STEERING COLUMN COVER TO ACCESS THE SWITCHES BETTER AND INSTALL THE GROMMET BUTTON
I replace both switches on mine and install another type of grommet because I’m waiting for the replacement to be delivered. Lights are off, but after a few hours they turn back on. Not sure what the issue is.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top