Nissan Forum banner

1 - 5 of 5 Posts

·
im2kwik4u
Joined
·
188 Posts
Discussion Starter #1
this happened to me yesterday on the higway, that whenever i go like 70+ mph, i feel like i dont have full control of the steering, sometimes i feel like the car steers itself sometimes, but this is only at high speeds on the highway, in the city it feels normal
i have had a recent problem before with my right axle ,that it had to be replaced like 5 times until i finally got one raxles and that fixed my problem, so maybe it could be that it threw it out of alignment because everytime they took the axles out they unbolted the tie rods out of the spindle????
or could it be something else
 

·
Destroyer of worlds.
Joined
·
874 Posts
it probably is out of allighnment, but that shouldn't give it a loose feel at 70mph. mine's out of allighnment too and feels fine.

i would gander that your front suspension is a little worn, but im not sure.
 

·
Registered
Joined
·
94 Posts
from the way you describe it my car kinda has the same feel to it... Like at lower than 65 the car feels pretty solid but you hit 65+ it just feels loose and kinda unsteady. Not really like its steering itself but w/ me it feels more like when i turn the wheel it wants to go the other direction for a sec and then it starts to go the way i'm turning, and even moving the wheel slightly makes the entire car rock. I think my struts might be bad(car has 125k miles on it and they're probably original) but i'm not sure. I might get some GR2's and leave it be.
 
1 - 5 of 5 Posts
Top