Nissan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
So I was driving to the casino one day and suddenly I hear my subs thumping away.... By that I mean, they just keeep thumping even though the music is turned down. It's really getting annoying and I want to know if anyone knows what the problem is. It only does it at random times, just out of the blue...and when I turn up the volume, the beat of the thump increases...I talked to my friends and they NEVER had a problem with this before. I'm thinking its my wiring, but I dont know where to start. Im running a 500watt JL amp, with 2 x 12" JL subs. I currently turned them off because its annoying me...i want to get it fixed ASAP...please help.

This also happened to me last year with a cheap amp I bought at wal-mart...I threw it away and bought a JL amp and it came back...any suggestions???

My ride:
95 nissan 200sx
1.6L 5 spd manual
 

·
new motor & tranny
Joined
·
1,756 Posts
i think its your wiring. Mine act weird sometimes cause of the loose wires on the amp. Like if ill be driving ill sometimes hear the subs hiting even tho there is like no bass in the song, or if someone is sitting at the back seat and they move around i can hear the bass thumping even if the volume is very very low and you normally dont hear the bass.
By the way i dont have JL but i have Phoenix Gold Amp & Subs.
 

·
Red line chaser
Joined
·
814 Posts
Check your RCA cables and also check your system grounds.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #6
okay so its either ground, or rca....with a show of votes...who thinks its ground and who thinks its RCA? I really dont want to buy new RCA cables because they cost a GRIP for good ones...I currently have monster RCA cables and they cost me an arm. 55 bux? I am not going to spend another 55 unless it's the main problem
 

·
Registered
Joined
·
50 Posts
Buy an RCA at Circuit City or Best Buy and try it. IF that's not it return within 30 days for a full refund ;)
 

·
Registered
Joined
·
44 Posts
Discussion Starter #9
Thanks everybody!...Yesterday I checked my ground, and found out that I grounded it in a drity place soI guess thats why it was thumping...but thanks for all your inputs....this thread can be closed now...
 
1 - 9 of 9 Posts
Top