Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
94 Altima, 151K. The alternator light and brake light both stay on after a cold start up and stay on until the engine warms up to normal range. Before they go off completely they flash on and off a few times. The alternator is a recently installed NAPA rebuilt Denso and must be working perfectly since the battery stays fully charged and the light has been doing this for almost a month now. The brakes are in good shape and the fluid level is good. What puzzles me most is that the alternator light and brake warning light both go on and off in perfect synchronization with each other, and one is never on or off without the other. Ideas anyone?

BTW, I have talked to 2 mechanics about the problem and neither of them has ever heard of this kind of thing before, and neither one had any idea what would cause it. Meanwhile the car has been starting, braking, and running daily for 3+ weeks and approximately 300 miles with no problems other than the warning lights staying on.
 

·
My ass, your face
Joined
·
3,520 Posts
i had similar problems with my car recently...electrical problems are a bitch to figure out, i'll tell u that. normally, those 2 lights flashing simultaneously means its the alternator(or the IC regulator not receiving enough power)......do the lights ever go off? and is the problem affected by speed? it was on my car...so it helped me narrow down my problem.
 

·
Biru O' Kudasai
Joined
·
1,426 Posts
What is the output amperage of your alternator? You can do a check at home by turning everything on like the high beams on, the A/C on, the fan on high. the radio on, the wipers on, etc. If the charge light and the brake are visible then the charging system has a problem. It could even be issues with a ground or poor connections on the positive cabling.

Troy
 

·
Registered
Joined
·
60 Posts
Discussion Starter #4
Thanks to both you and ChOps for the replies. I was hoping for an easy answer, but should have known it wouldn't be that easy. Oh well, can't complain I guess. After 151K the only other problems the car has had other than the alternator was a stuck air gate in the vent ducting and water in the gas tank, which was caused by me buying gas at an el cheapo gas station. Easily the most trouble free car I have ever owned.

I guess I had better get the old buggy down to the shop which installed the new alernator a few months ago. I called them and they said the alternator is under warranty for a year. So far all the electric accessories are working OK, but I don't want to go out one cold morning and find a dead battery.
 
1 - 4 of 4 Posts
Top