Nissan Forum banner

161 - 169 of 169 Posts

·
Registered
Joined
·
7 Posts
My Nissan Altima 2002 2.5S won't start with the SES warning light on, I got two error codes by using this manual checking method.

P0340, Camshaft Position Sensor Circuit Malfunction
P1612, Engine Control Module Incorrect Coding

Does any one know anything about these errors and possible causes?

I tried to reset the code, but it did not.

Will I be able to start the car and drive to the dealer in safe mode if I clear the error code?

Please help if you can. Thanks in advance!!!


I know I'm a few months off....and I'm sure you got this fixed, but in case anyone eles has this problem, there was a recall on this part from nissan. This will fail on you while driving and cause the engine to quit without the ability to restart. This quote is from Nissanhelp.com:


2000-2003 SENTRA, MAXIMA, 2002 ALTIMA, 2003 MURANO, 350Z; VOLUNTARY RECALL CAMPAIGN ENGINE SENSORS
Nissan has determined that some 2000-2003 model year Nissan vehicles may have a defect which relates to motor vehicle safety. The engine might stop running while being driven if the crank position sensor or cam position sensor fails. This may also result in the "Service Engine Soon" light coming on or reduced engine power. If the engine stops running while driving, this could result in a crash without warning.
 

·
Registered
Joined
·
4 Posts
Thank you so much for posting this. It took me a few tries to get the timing correct (I didn't have a second hand on my watch, and was saying "mississippi" between seconds), but I nearly fell out of the door when it worked and started blinking. Thanks again.
 

·
Registered
Joined
·
1 Posts
Should this procedure for DTM work for a 1999 Altima? Tried a bunch of time and could never get the MIL to flash...used stopwatch and everything. Maybe only works on 2002's and newer?

If anyone knows for certain, please let me know. Thanks!
 

·
Registered
Joined
·
2 Posts
Please, need help reading codes

Hi, My Xtrail 2003 2.2 dci has been putting itself in limp home mode occasionally when you come to a halt (e.g. at traffic lights) for about 2 years now. The nearset official Nissan garage in Spain were unable to help, they didnt even know how to work the laptop to get the codes out, I had to tell them the codes I read how to get on this forum.

Now the car is permanently in limp home mode. The code reads as follows:

1 2 7 4 1 2 7 3 13(slow) 10 10 10(slow) 10 10 8 9 1 2 7 1

I have videoed the flashes, and treble checked the above is exactly what I see.

The question is, what do these mean? I cant find them in any lists.

The previous pair of codes I got a couple of years ago indicated a problem with the high pressure fuel pump, and the second code Nissan didn't know what it meant, and could not find on forums.

Many thanks for any help!
 

·
Registered
Joined
·
11 Posts
MIL

I realize it's been a while since you posted these instructions, but My light is ON....
I tried the routine you described several times ensuring I got the timing as accurate as poss..
Nothing.. The damn light just keeps glowing at me??
How else can I get into the Diagnostic Mode?
 

·
Registered
Joined
·
1 Posts
self

bought 2004 murano brand new in 6 months change alternator 4 times asked mechanic why mechanic said is like a light bulb they go:(
 
161 - 169 of 169 Posts
Top