Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
For some reason, my AC will no longer turn on, I don't even feel lag from the pump when it should engage the pulley... I hope its a easy fix, but do any of you have an idea? I just dropped in my new Injen CAI. Is it possible that i just blue a fuse and now my pump wont engage, or did i brake something doing my drag test to figure my performance gains?
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,227 Posts
This could be a variety of things.
Check that the clutch is not engaging by eye. the pully spins but the center remains stationary.
If the Freon is low the low pressure switch opens and prevents the clutch from Engaging.
So either check with a meter sw is ok or gauges check for Freon pressure.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
Turnd out to be a curoded plug. Cleaned and functional again.
 

·
Registered
Joined
·
107 Posts
This could be a variety of things.
Check that the clutch is not engaging by eye. the pully spins but the center remains stationary.
If the Freon is low the low pressure switch opens and prevents the clutch from Engaging.
So either check with a meter sw is ok or gauges check for Freon pressure.
I feel stupid but could you guys let me know where the compressor clutch is. I need to recharge the ac but heard that I may need to jump the clutch.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,227 Posts
No you must not jump the clutch, if you do you risk destroying the compressor.
The compressor uses freon to carry the Oil, if there is no pressue, ie no freon, there is no Oil to the moving parts.
You must charge the A/C so the pressure switches are made, then the compressor will work.
This is not a problem, the can of Freon is at high pressure and just flows in when connected up to the system.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,227 Posts
The clutch is at the belt end of the compressor.
 
1 - 6 of 6 Posts
Top