Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
tha abs light came on shortly after replacing my distributor. Not there is any connection, just happened thatb way '94 altima 2.4 auto. Maybe there mihgt be some help out there.
 

·
Registered
Joined
·
6 Posts
motorhead said:
tha abs light came on shortly after replacing my distributor. Not there is any connection, just happened thatb way '94 altima 2.4 auto. Maybe there mihgt be some help out there.
Did any other lights come on at the same time? I had the ABS light and the check engine light come on at the same time, it ended up being the alternator. The auto parts store tested the alternator and said it was fine (little did they know)
 

·
Biru O' Kudasai
Joined
·
1,426 Posts
First check all the fuses and fusible links under the hood and under the dash. To enter self-diagnosis mode for the ABS
1) Drive the car over 20 mph for at least a minute.
2) Turn off the the ignition switch.
3) Ground the data link terminal "L", which is located on the upper corner of the interior fuse panel. Terminal "L" is in the bottom row and fourth from the left;
I-I--I--I--I
I-I--Ix-I--I
4) Turn the ignition switch on but DO NOT press the brake pedal with the "L" terminal grounded.
5) after about 4 seconds the warning lamp will start flashing the malfunction code(s).

If the warning lamp does not blink the solenoid valve relay is stuck or control module power has a problem.
The long flashes are the the tens digit and the short flashes are the single digits.
If you find out the code(s) I can give you the circuit causing it.

Troy
 

·
Registered
Joined
·
29 Posts
My ABS Light Problem and Solution

I had the dreaded ABS light come again. It would only come on after I stepped on the brake pedal if I had the headlights on. Once on, it would not go off until I shut the car.

I decided to check the brake lights and noticed that only one of the four brake lights in the tail light assembly was working. I changed all of the 1157 bulbs in the assembly with no luck.

Started to check the connections and realized that the negative (ground) wire for each bulb in the tail light assembly was a little corroded. Decided to unscrew each, clean, and reconnect.

Voila. All the 1157 brake lights work and best of all the ABS light no longer comes on.

Hope this helps someone else.

-mvcooper
 
1 - 5 of 5 Posts
Top