Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2002 Nissan Altima Sedan with a 3.5 L engine. My ABS light is on and my ABS doesn't come on. When a code reader is hooked up the computer doesn't output a code. I replaced one of the ABS speed sensor that was broken hoping it would fix the issue and it didn't. I've also replaced the rotors and bad on the back because one of them was warped and I thought it might fix the issue and it still didn't. I checked and tested all of the fuses that have to do with the ABS in the engine bay and they're all good. Any idea what this might be?
 

·
NF Mod/Nissan Master Tech
Joined
·
9,389 Posts
Are you using a generic OBD II code reader that just reads P-codes or do you have a scan tool that can read C-codes? ABS codes are chassis codes and need to be read by a diagnostic tool that can read such codes.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Are you using a generic OBD II code reader that just reads P-codes or do you have a scan tool that can read C-codes? ABS codes are chassis codes and need to be read by a diagnostic tool that can read such codes.
It's not my code reader, but I know it has an option to read check engine light codes and ABS light codes separately.
 

·
NF Mod/Nissan Master Tech
Joined
·
9,389 Posts
I'm not really sure what you mean by that? Does the reader communicate with the ABS system or do you just not know how to access the ABS codes with the tool that you are using? If you can communicate but not get codes and the warning light stays on, you "may" have a faulty ABS control unit. You would be best to take a look at the ABS section in the factory service manual for diagnostic assistance. NICO Club's site has free online access to their Nissan manuals which you can use.
 
1 - 4 of 4 Posts
Top