Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I know needy for first post, but check the newbie board and you'll see what the llast year has brought, anyway the header says almost it all but for the non readers I'l recap in detail

Had obviously bad v Reg ( dim lights then batt foaming v undulation ect ) :wtf: :wtf:
Had overcharging problems including foaming dripping Batt
Changed Alt
After funk has grown on batt terminals ABS, BATT, and BRK lights on all the time
Signs of batt not charging (ie dim lights, dash dimming out)

So the question is does the general public think it's the new ALT or possibly the build up of crap on the terminals?? NORMALLY I would not ask such a (possibly) simple question but ( again ) the last year has sucked and a good awnser would be a great help.

Thanks!!!!!!!!!
 

·
Will work for beer
Joined
·
2,696 Posts
sounds like the alternator wire isn't connected or it's not charging..

clean the terminals up and replace the battery if needed.

check system voltage with engine running at idle. make sure you have more than 12.8V. (at idle, these alternators are a tad low sometimes)...
check directly on the battery posts, on the terminals right next to the posts, and on the wire coming from the alternator (even the back of the alternator)

Also make sure you got the small sensing wires hooked back up to the alternator.. if they're not connected, the alternator won't charge and you will get the same lights on the dash.

several things to look at.. go over everything again and come back... shouldn't take but a 1/2 hour or so to do all that.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thank you for the tips, turns out it was a bad alt, heck either that or I had the dang belt too tight and burned it out, but I exchanged out the alt and now she's putting out 13-13.8v at IDLE!!! ( Shameless plug follows ) THANK GOD for Chatham Street Auto Parts in Cary. Thoes guys ALWAYS have the part cheaper and 90% of the time in stock, heck when I called about a bad alt I had purchased less than 2 weeks prior they already had replacements in stock. Gotta Love that. Better yet the MAX is purring, and charging :thumbup:
 
1 - 3 of 3 Posts
Top